Project

General

Profile

Actions

Feature #10218

closed

[Crunch2] Gather and record cloud/physical node information for each container

Added by Ward Vandewege over 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
03/20/2017
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
1.0
Release:
Release relationship:
Auto

Description

Crunch2 already computes the runtime_constraints for a container based on defaults and what is in the corresponding container_request object.

It would be useful to have more detail about the physical or cloud node that executes the container. Specifically, in the cloud, it would be helpful if this was a Dv2 node, or an A node, for example, because those cores are not equal.

In an on-prem environment (as well as in the cloud, actually), it would be useful to know the cpu model.

Maybe crunch-run can record some basic facts about the hardware its running on and record those in the container object for future inspection.

Things to log as a starting point:

crunch-run version

copy of the container record as "container.json"

$ uname -a
$ cat /proc/cpuinfo
$ cat /proc/meminfo
$ df # for available scratch space

contents of /var/tmp/arv/node/data

Logged using standard logging structure a la crunchstat, etc.


Subtasks 1 (0 open1 closed)

Task #11199: Review 10218-record-node-infoResolvedTom Clegg03/20/2017

Actions

Related issues

Related to Arvados - Story #7711: [Node Manager] Record a node's cloud cost information in the Arvados node record's propertiesResolvedTom Clegg11/03/2015

Actions
Related to Arvados - Feature #10217: [Crunch1] Log the node properties at the start of a jobClosed

Actions
Is duplicate of Arvados - Feature #8196: [Crunch] Jobs should log the hardware of their compute node(s)Duplicate01/12/2016

Actions
Actions

Also available in: Atom PDF