Bug #10520

[CrunchV2] arvados-cwl-runner unhandled error when using --create-template

Added by Ward Vandewege about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

When running arvados-cwl-runner --create-template on a CrunchV2 only setup, it errors out like this

shell.9tee4:/usr/local/arvados/src/doc/user/cwl/bwa-mem$ arvados-cwl-runner --create-template bwa-mem.cwl
/usr/bin/arvados-cwl-runner c6c3d3c8748b59ca0e8a9d5cfec0a54bdfd212f0 1.0.20161110143547, arvados-python-client 0.1.20161103194513, cwltool 1.0.20161107145355
2016-11-11 03:24:45 arvados.arv-run[11967] INFO: Upload local files: "bwa-mem.cwl" 
2016-11-11 03:24:45 arvados.arv-run[11967] INFO: Uploaded to 9tee4-4zz18-z3esag8l0zux5lr
Unhandled error, try again with --debug for more information:
  'Resource' object has no attribute 'create'

Instead of erroring out, it should say that --create-template is not supported, and that --create-workflow should be used instead.


Related issues

Is duplicate of Arvados - Feature #10498: [CWL] Single --register subcommand selects workflow or pipelineResolved11/17/2016

History

#1 Updated by Ward Vandewege about 5 years ago

  • Description updated (diff)

#2 Updated by Ward Vandewege about 5 years ago

  • Project changed from OPS to Arvados

#3 Updated by Tom Clegg about 5 years ago

  • Status changed from New to Feedback

#4 Updated by Tom Clegg about 5 years ago

  • Status changed from Feedback to Resolved

#5 Updated by Tom Morris almost 5 years ago

  • Target version deleted (Arvados Future Sprints)

Also available in: Atom PDF