Bug #10838

[Workbench] "#<NoMethodError: undefined method `output_name' for #<ContainerRequest:0x0000000557ac60>>"

Added by Ward Vandewege over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Immediate
Assigned To:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Story points:
-

Description

All our auto-deployed setups are showing the above error message on the dashboard page of Workbench.

Associated revisions

Revision 5926f360 (diff)
Added by Ward Vandewege over 4 years ago

In our rails postinstall package script, when looking for the
'database:' line, make sure to match every line of the rake
db:migrate:status output, not just the first one.

refs #10838

Revision 45772b70 (diff)
Added by Ward Vandewege over 4 years ago

In our rails postinstall package script, preserve newlines when looking
for the '^database:' line, so that we match every line of the rake
db:migrate:status output, not just the first one.

refs #10838

Revision 84968bda
Added by Ward Vandewege over 4 years ago

Merge branch '10838-fix-rails-package-postinst'

closes #10838

Revision 85f8ab2e (diff)
Added by Ward Vandewege over 4 years ago

Bump up rails package iteration.

refs #10838

History

#1 Updated by Ward Vandewege over 4 years ago

  • Description updated (diff)

#2 Updated by Ward Vandewege over 4 years ago

  • Priority changed from Normal to Immediate

#3 Updated by Lucas Di Pentima over 4 years ago

  • Status changed from New to In Progress
  • Assigned To set to Lucas Di Pentima

#4 Updated by Ward Vandewege over 4 years ago

  • Assigned To changed from Lucas Di Pentima to Ward Vandewege

This turned out to be caused by the db migrations: they didn't run.

And that was a consequence of the fix by tom in d7b27f798a0298f5508842c5f7f03b8fccafa3ab and the way we test for the db migration status in postinst.sh.

I've got a patch in branch 10838-fix-rails-package-postinst

#5 Updated by Ward Vandewege over 4 years ago

  • Target version set to 2017-01-18 sprint

#6 Updated by Ward Vandewege over 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Applied in changeset arvados|commit:84968bdae36586c875a50cc82662de84a5118dfa.

Also available in: Atom PDF