Bug #10844

[API] arv-keepdocker fails with undefined method trash_at_changed?

Added by Ward Vandewege over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

As of 85f8ab2ef898f8d0bb7187db6db59a93ac528ec5


wardv@shell:~$ /usr/local/rvm/bin/rvm-exec default arv keep docker --pull --project-uuid=su92l-j7d0g-m7id76y7kox589f arvados/jobs 495a7df016f63ae348000b1c046f8e1c5f1c5903
495a7df016f63ae348000b1c046f8e1c5f1c5903: Pulling from arvados/jobs
Digest: sha256:d05d5bd02d5fe55d774c1179b5c3c5c399695abe859de8cce5afe8604d9dd5e8
Status: Image is up to date for arvados/jobs:495a7df016f63ae348000b1c046f8e1c5f1c5903
358M / 358M 100.0% 2017-01-09 15:42:22 arvados.arv_put[65428] ERROR: arv-put: <HttpError 422 when requesting https://su92l.arvadosapi.com/arvados/v1/collections?ensure_unique_name=true&alt=json returned "#<NoMethodError: undefined method `trash_at_changed?' for #<Collection:0x007fe2614abac8>>">

History

#1 Updated by Ward Vandewege over 4 years ago

  • Description updated (diff)

#2 Updated by Ward Vandewege over 4 years ago

  • Status changed from New to Resolved
  • Target version set to 2017-01-18 sprint

Caused by migrations that didn't run because of a deploy problem on su92l.

Also available in: Atom PDF