Bug #10955

arvados-cli gem dependency error

Added by Javier BĂ©rtoli almost 2 years ago. Updated over 1 year ago.

Status:
New
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
Start date:
01/24/2017
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

When installing the arvados-cli gem on my local machine, it installs OK, but get dependency errors when running it:

arv

Error loading gems: Unable to activate arvados-0.1.20160513152536, because json-2.0.3 conflicts with json (>= 1.7.7, ~> 1.7)

Please install all required gems:

  gem install arvados activesupport andand curb json oj trollop

javier@agnes:~/.../curoverse/arvados-dev$ gem list|egrep "arvados|activesupport|andand|curb|json|oj|trollop" 
activesupport (5.0.1, 3.2.22.5)
andand (1.3.3)
arvados (0.1.20160513152536)
arvados-cli (0.1.20170118222913)
curb (0.9.3)
json (2.0.3, 1.8.3)
json_pure (2.0.3, 1.8.3)
multi_json (1.12.1)
oj (2.18.1)
trollop (2.1.2)

History

#1 Updated by Tom Morris almost 2 years ago

  • Subject changed from arvados-cli gem dependecy error to arvados-cli gem dependency error

#2 Updated by Tom Morris over 1 year ago

  • Target version set to Arvados Future Sprints

Also available in: Atom PDF