Bug #11236

Dependencies in Ubuntu 16.04 (xenial) offer to REMOVE arvados-node-manager

Added by Javier Bértoli 5 months ago. Updated 5 months ago.

Status:ResolvedStart date:03/09/2017
Priority:HighDue date:
Assignee:Nico César% Done:

100%

Category:Node Manager
Target version:2017-03-29 sprint
Story points-
Velocity based estimate-

Description

Performing a dist-upgrade on an Ubuntu 16.04 (xenial) host offers to REMOVE arvados-node-manager

  • Sources lists:
    deb http://apt.arvados.org/ xenial main
    deb http://mirrors.us.kernel.org/ubuntu/ xenial main universe
    deb-src http://mirrors.us.kernel.org/ubuntu/ xenial main universe
    deb http://security.ubuntu.com/ubuntu/ xenial-security main universe
    deb-src http://security.ubuntu.com/ubuntu/ xenial-security main universe
    deb http://mirrors.us.kernel.org/ubuntu/ xenial-updates main universe
    deb-src http://mirrors.us.kernel.org/ubuntu/ xenial-updates main universe
    
  • Current arvados packages installed in the host:
    # dpkg -l |grep arva
    ii  arvados-node-manager                0.1.20170307182544-2           all          The Arvados node manager
    ii  python-arvados-python-client        0.1.20170309194426-2           all          The Arvados Python SDK
    
  • Packages offered to be removed when running apt-get dist-upgrade:
    The following packages will be REMOVED:
      aptitude arvados-node-manager libasprintf0c2 libkdb5-7 libperl5.18
      libpython3.4-minimal libpython3.4-stdlib libxapian22 perl-modules
      python-arvados-python-client python-chardet-whl python-colorama-whl
      python-distlib-whl python-html5lib-whl python-requests-whl
      python-setuptools-whl python-six-whl python-urllib3-whl python3.4
      python3.4-minimal slurm-llnl-basic-plugins systemd-services
    
  • Reported dependencies for the arvados-node-manager package:
    Dependencies: 
    0.1.20170307182544-2 -
    
    python-apache-libcloud (2 0.16) 
    python-arvados-python-client (2 0.1.20150206225333) 
    python-pykka (0 (null)) 
    python-daemon (0 (null)) 
    python-setuptools (0 (null)) 
    python-setuptools (0 (null)) 
    python2.7 (0 (null)) 
    
  • Installed versions of the dependencies (candidate listed only when != installed):
    python-apache-libcloud:
      Installed: 0.20.2.dev3-2
    
    python-arvados-python-client:
      Installed: 0.1.20170309194426-2
    
    python-pykka:
      Installed: 1.2.1-2
    
    python-daemon:
      Installed: 1.5.5-1ubuntu1
      Candidate: 2.0.5-1
    
    python-setuptools:
      Installed: 20.7.0-1
    
    python2.7:
      Installed: 2.7.6-8ubuntu0.3
      Candidate: 2.7.12-1ubuntu0~16.04.1
    

History

#1 Updated by Javier Bértoli 5 months ago

  • Target version changed from 2017-03-15 sprint to 2017-03-29 sprint

#2 Updated by Nico César 5 months ago

  • Assignee set to Nico César

#3 Updated by Javier Bértoli 5 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Run

apt-get update
apt-get dist-upgrade

Only python-openssl was kept back. Tried to see if it was due to some arvados-* dependency, but could be upgraded with no issues, with:
apt-get install python-openssl python-cryptography python-pyasn1=0.1.9-1

and all upgraded OK. Current versiones installed are
arvados-node-manager                  0.1.20170323201633-2
python-arvados-python-client          0.1.20170327195441-2

So I think this can be considered solved

Also available in: Atom PDF