Bug #11237

python-arvados-python-client depends on old versions of packages

Added by Javier Bértoli 14 days ago. Updated 8 days ago.

Status:NewStart date:03/09/2017
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Workbench
Target version:-
Story points-
Velocity based estimate-

History

#1 Updated by Javier Bértoli 14 days ago

  • Category set to Workbench

When updating an Ubuntu 16.04 host, python-arvados-python-client complains that the available versions are not suitable for the upgrade, and need to force dependencies:

The following packages have unmet dependencies:
 python-arvados-python-client : Depends: python-oauth2client (< 2) but 2.0.1-1 is to be installed
                                Depends: python-pycurl (< 7.21.5) but 7.43.0-1ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.
Error: /Stage[main]/Arvados-workbench-server/Package[python-arvados-python-client]/ensure: change from purged to latest failed: Could not update: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-arvados-python-client' returned 100: Reading package lists...
Building dependency tree...
...
...
The following packages have unmet dependencies:
 python-arvados-python-client : Depends: python-oauth2client (< 2) but 2.0.1-1 is to be installed
                                Depends: python-pycurl (< 7.21.5) but 7.43.0-1ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.

Current versions available in Ubuntu:

python-pycurl:
  Version table:
     7.43.0-1ubuntu1 500
        500 http://mirrors.us.kernel.org/ubuntu xenial/main amd64 Packages

python-oauth2client:
  Version table:
     2.0.1-1 500
        500 http://mirrors.us.kernel.org/ubuntu xenial/universe amd64 Packages

#2 Updated by Tom Clegg 8 days ago

This pin comes from ec3ff9b4 "Pin google-api-python-client and oauth2client versions to deal with incompatability between google api client and oauth2 client 2.0. no issue #"

Also available in: Atom PDF