Bug #11397

[Ruby 2.3.3] Make json gem dependency > 1.7.7

Added by Nico C├ęsar 5 months ago. Updated 5 months ago.

Status:ResolvedStart date:03/30/2017
Priority:NormalDue date:
Assignee:Tom Clegg% Done:

0%

Category:-
Target version:-
Story points-
Velocity based estimate-

Description

gem json 1.7.7 doesn't compile in distros nowadays . If this is not a hard dependency for arvados, will be good to have 1.8.x or even better 2.x version:

# rvm 2.3.3 do gem install json -v 1.7.7 
Building native extensions.  This could take a while...
ERROR:  Error installing json:
        ERROR: Failed to build gem native extension.

    current directory: /usr/local/rvm/gems/ruby-2.3.3/gems/json-1.7.7/ext/json/ext/generator
/usr/local/rvm/rubies/ruby-2.3.3/bin/ruby -r ./siteconf20170329-31235-1rng2qn.rb extconf.rb
creating Makefile

current directory: /usr/local/rvm/gems/ruby-2.3.3/gems/json-1.7.7/ext/json/ext/generator
make "DESTDIR=" clean

current directory: /usr/local/rvm/gems/ruby-2.3.3/gems/json-1.7.7/ext/json/ext/generator
make "DESTDIR=" 
compiling generator.c
In file included from generator.c:1:0:
../fbuffer/fbuffer.h: In function 'fbuffer_to_s':
../fbuffer/fbuffer.h:175:47: error: macro "rb_str_new" requires 2 arguments, but only 1 given
     VALUE result = rb_str_new(FBUFFER_PAIR(fb));
                                               ^
../fbuffer/fbuffer.h:175:20: warning: initialization makes integer from pointer without a cast
     VALUE result = rb_str_new(FBUFFER_PAIR(fb));
                    ^
Makefile:238: recipe for target 'generator.o' failed
make: *** [generator.o] Error 1

make failed, exit code 2

Gem files will remain installed in /usr/local/rvm/gems/ruby-2.3.3/gems/json-1.7.7 for inspection.
Results logged to /usr/local/rvm/gems/ruby-2.3.3/extensions/x86_64-linux/2.3.0/json-1.7.7/gem_make.out

History

#1 Updated by Tom Clegg 5 months ago

  • Assignee set to Tom Clegg
  • Status changed from New to Resolved

arvados and arvados-cli gems accept 1.8.x.

New gems aren't published yet but as of 78ca1460d58172f4555409298968583cd2ee70a1 they also accept 2.x.

Hopefully then nobody has to be in the position of figuring out that "~> 1.7, >= 1.7.7" can be satisfied by manually installing 1.8.6.

Also available in: Atom PDF