Project

General

Profile

Actions

Feature #11646

closed

[keepstore] Support X-Keep-Desired-Classes header

Added by Tom Clegg almost 6 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assigned To:
-
Category:
Keep
Target version:
-
Start date:
05/09/2017
Due date:
% Done:

0%

Estimated time:
Story points:
1.0

Description

Part of the Keep storage classes story.

Accept X-Keep-Desired-Classes header in write requests.
  • If X-Keep-Desired-Classes header is missing, use class "default".
  • If X-Keep-Desired-Classes header is invalid (example?), return a 422 error.
  • When writing data, only write to a volume that satisfies all of the desired classes.
  • When checking whether data already exists, only check volumes that satisfy all of the desired classes.

Related issues

Is duplicate of Arvados - Feature #13382: [keepstore] Write new blocks to appropriate storage classResolvedTom Clegg04/02/2021

Actions
Actions #1

Updated by Tom Morris almost 6 years ago

  • Story points set to 1.0
Actions #2

Updated by Tom Morris over 5 years ago

  • Target version set to Arvados Future Sprints
Actions #3

Updated by Tom Clegg about 5 years ago

  • Subject changed from [keepstore] Support X-Keep-Desired-Tier header to [keepstore] Support X-Keep-Desired-Classes header
  • Description updated (diff)
Actions #4

Updated by Tom Clegg almost 5 years ago

  • Status changed from New to Closed
  • Target version deleted (Arvados Future Sprints)

dup #13382

Actions #5

Updated by Tom Clegg almost 5 years ago

  • Is duplicate of Feature #13382: [keepstore] Write new blocks to appropriate storage class added
Actions

Also available in: Atom PDF