Story #12037

[CWL] Pass conformance for v1.0.1

Added by Peter Amstutz almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
07/27/2017
Due date:
% Done:

0%

Estimated time:
(Total: 0.00 h)
Story points:
0.5

container.json (5.84 KB) container.json Lucas Di Pentima, 07/28/2017 02:11 PM
crunch-run.txt (837 Bytes) crunch-run.txt Lucas Di Pentima, 07/28/2017 02:11 PM
crunchstat.txt (854 Bytes) crunchstat.txt Lucas Di Pentima, 07/28/2017 02:11 PM
stderr.txt (5.48 KB) stderr.txt Lucas Di Pentima, 07/28/2017 02:11 PM
node-info.txt (6.23 KB) node-info.txt Lucas Di Pentima, 07/28/2017 02:11 PM

Subtasks

Task #12040: Review 12037-cwl-v1.0.1ResolvedLucas Di Pentima

Associated revisions

Revision 386e1eef
Added by Peter Amstutz almost 2 years ago

Merge branch '12037-cwl-v1.0.1' closes #12037

Arvados-DCO-1.1-Signed-off-by: Peter Amstutz <>

History

#1 Updated by Peter Amstutz almost 2 years ago

  • Status changed from New to In Progress
  • Assigned To set to Peter Amstutz

#2 Updated by Lucas Di Pentima almost 2 years ago

Reviewing updates at 0c817f2f9

Followed guide on https://dev.arvados.org/issues/11948#note-4 to run conformance tests on a local arvbox instance, and many tests failed:

Test [108/108] 
40 tests passed, 64 failures, 4 unsupported features

1 tool tests failed

Ran some failing tests manually, this is what I got:

(venv)lucas@curoverse:~/common-workflow-language$ /home/lucas/venv/bin/arvados-cwl-runner --api=containers --compute-checksum --disable-reuse --outdir=/tmp/tmpGUvLgn --debug v1.0/shellchar2.cwl v1.0/empty.json
2017-07-27 17:10:41 cwltool INFO: /home/lucas/venv/bin/arvados-cwl-runner 0c817f2f98fc9f15bf36ec226da2e72afb34edd5 1.0.20170727113430, arvados-python-client 0.1.20170717175001, cwltool 1.0.20170727112954
2017-07-27 17:10:41 cwltool DEBUG: Search path is ['/home/lucas/common-workflow-language/v1.0/shellchar2.cwl', '/home/lucas/.local/share/commonwl/v1.0/shellchar2.cwl', '/usr/share/xfce4/commonwl/v1.0/shellchar2.cwl', '/usr/local/share/commonwl/v1.0/shellchar2.cwl', '/usr/share/commonwl/v1.0/shellchar2.cwl', '/usr/share/commonwl/v1.0/shellchar2.cwl']
2017-07-27 17:10:41 cwltool INFO: Resolved 'v1.0/shellchar2.cwl' to 'file:///home/lucas/common-workflow-language/v1.0/shellchar2.cwl'
2017-07-27 17:10:41 cwltool ERROR: Tool definition failed initialization:
[Errno 2] No such file or directory: '/home/lucas/common-workflow-language/v1.0/shellchar2.cwl'
Traceback (most recent call last):
  File "build/bdist.linux-x86_64/egg/cwltool/main.py", line 795, in main
    fetcher_constructor=fetcher_constructor)
  File "build/bdist.linux-x86_64/egg/cwltool/load_tool.py", line 66, in fetch_document
    workflowobj = document_loader.fetch(fileuri)
  File "build/bdist.linux-x86_64/egg/schema_salad/ref_resolver.py", line 868, in fetch
    text = self.fetch_text(url)
  File "build/bdist.linux-x86_64/egg/arvados_cwl/fsaccess.py", line 173, in fetch_text
    return super(CollectionFetcher, self).fetch_text(url)
  File "build/bdist.linux-x86_64/egg/schema_salad/ref_resolver.py", line 154, in fetch_text
    raise RuntimeError(six.text_type(e))
RuntimeError: [Errno 2] No such file or directory: '/home/lucas/common-workflow-language/v1.0/shellchar2.cwl'
(venv)lucas@curoverse:~/common-workflow-language$ find . -name shellchar2.cwl
./v1.1.0-dev1/v1.1.0-dev1/shellchar2.cwl
./v1.0/v1.0/shellchar2.cwl
(venv)lucas@curoverse:~/common-workflow-language$ /home/lucas/venv/bin/arvados-cwl-runner --api=containers --compute-checksum --disable-reuse --outdir=/tmp/tmpsevmdA --debug v1.0/null-defined.cwl v1.0/empty.json
2017-07-27 17:25:19 cwltool INFO: /home/lucas/venv/bin/arvados-cwl-runner 0c817f2f98fc9f15bf36ec226da2e72afb34edd5 1.0.20170727113430, arvados-python-client 0.1.20170717175001, cwltool 1.0.20170727112954
2017-07-27 17:25:19 cwltool DEBUG: Search path is ['/home/lucas/common-workflow-language/v1.0/null-defined.cwl', '/home/lucas/.local/share/commonwl/v1.0/null-defined.cwl', '/usr/share/xfce4/commonwl/v1.0/null-defined.cwl', '/usr/local/share/commonwl/v1.0/null-defined.cwl', '/usr/share/commonwl/v1.0/null-defined.cwl', '/usr/share/commonwl/v1.0/null-defined.cwl']
2017-07-27 17:25:19 cwltool INFO: Resolved 'v1.0/null-defined.cwl' to 'file:///home/lucas/common-workflow-language/v1.0/null-defined.cwl'
2017-07-27 17:25:19 cwltool ERROR: Tool definition failed initialization:
[Errno 2] No such file or directory: '/home/lucas/common-workflow-language/v1.0/null-defined.cwl'
Traceback (most recent call last):
  File "build/bdist.linux-x86_64/egg/cwltool/main.py", line 795, in main
    fetcher_constructor=fetcher_constructor)
  File "build/bdist.linux-x86_64/egg/cwltool/load_tool.py", line 66, in fetch_document
    workflowobj = document_loader.fetch(fileuri)
  File "build/bdist.linux-x86_64/egg/schema_salad/ref_resolver.py", line 868, in fetch
    text = self.fetch_text(url)
  File "build/bdist.linux-x86_64/egg/arvados_cwl/fsaccess.py", line 173, in fetch_text
    return super(CollectionFetcher, self).fetch_text(url)
  File "build/bdist.linux-x86_64/egg/schema_salad/ref_resolver.py", line 154, in fetch_text
    raise RuntimeError(six.text_type(e))
RuntimeError: [Errno 2] No such file or directory: '/home/lucas/common-workflow-language/v1.0/null-defined.cwl'
(venv)lucas@curoverse:~/common-workflow-language$ find . -name null-defined.cwl
./v1.0/v1.0/null-defined.cwl

Is this some cwl mistake or something is wrongly configured on my local setup?

#3 Updated by Peter Amstutz almost 2 years ago

You need to cd in to the "v1.0" directory before you paste the command line.

#4 Updated by Lucas Di Pentima almost 2 years ago

Attaching log files from a failed conformance test run on my arvbox setup

#5 Updated by Lucas Di Pentima almost 2 years ago

Adding environment information.

pip freeze returns:

CacheControl==0.11.7
argparse==1.2.1
arvados-cwl-runner==1.0.20170727113430
arvados-python-client==0.1.20170717175001
avro==1.8.1
certifi==2017.7.27.1
chardet==3.0.4
ciso8601==1.0.3
cwltest==1.0.20170721135308
cwltool==1.0.20170727112954
future==0.16.0
futures==3.1.1
google-api-python-client==1.6.2
httplib2==0.10.3
idna==2.5
isodate==0.5.4
junit-xml==1.7
lockfile==0.12.2
mistune==0.7.4
oauth2client==4.1.2
pyasn1==0.3.1
pyasn1-modules==0.0.10
pycurl==7.43.0
pyparsing==2.2.0
rdflib==4.2.2
rdflib-jsonld==0.4.0
requests==2.18.2
rsa==3.4.2
ruamel.ordereddict==0.4.13
ruamel.yaml==0.13.7
schema-salad==2.6.20170712194300
shellescape==3.4.1
six==1.10.0
typing==3.5.3.0
uritemplate==3.0.0
urllib3==1.22
ws4py==0.3.5
wsgiref==0.1.2

Trying run the conformance tests from cwl repo, commit ffd2dbfc4a73937c91cfa05afa079f1609eff583

#6 Updated by Peter Amstutz almost 2 years ago

So the issue is that it is missing a Docker image tagged arvados/jobs:latest, compounded by the a logging bug that obscured the issue a bit.

It will now pull arvados/jobs:latest image if necessay. Now 12037-cwl-v1.0.1 @ d69024a630b907c930070fbfd24e61aad1070a70

#7 Updated by Lucas Di Pentima almost 2 years ago

All conformance tests now worked for me.
LGTM, thanks!

#8 Updated by Peter Amstutz almost 2 years ago

  • Status changed from In Progress to Resolved

Applied in changeset arvados|commit:386e1eefaac2021805f73732b10e9f543c221593.

Also available in: Atom PDF