Story #12189

Support generic resource requests for run time constraints

Added by Tom Morris over 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
-
Start date:
08/28/2017
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

In a similar fashion to the way SLURM does for Generic Resource Scheduling https://slurm.schedmd.com/gres.html

Basics are probably resource name & count, but may need additional parameters as well.


Related issues

Is duplicate of Arvados - Feature #12630: [Crunch2] GPU supportNew08/01/2018

History

#1 Updated by Peter Amstutz over 3 years ago

#2 Updated by Tom Morris almost 3 years ago

  • Status changed from New to Closed

#3 Updated by huanxiang lu over 1 year ago

Hello,

We are trying to fire some GPU nodes in the SLURM cluster, which requires the gpu model being specified. Clearly, Arvados doesn't support this parameter right now and we can't launch for GPU jobs. I wonder if this functionality is to be implemented or not.

Thanks,
Huan

#4 Updated by Tom Morris over 1 year ago

There is some support in #12630 (which this is a duplicate of).

Does that help or do you need more?

Also available in: Atom PDF