Project

General

Profile

Actions

Story #12197

closed

Add PDH column and filter to trash display

Added by Tom Morris almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
08/30/2017
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-

Files

12197-search-pdh.png (104 KB) 12197-search-pdh.png Tom Clegg, 09/13/2017 09:00 PM
12197-search-pdh-0923.png (69 KB) 12197-search-pdh-0923.png Tom Clegg, 09/18/2017 01:29 PM

Subtasks 1 (0 open1 closed)

Task #12202: Review 12197-show-pdh-in-trashResolvedTom Clegg08/30/2017

Actions
Actions #1

Updated by Tom Morris almost 5 years ago

  • Assigned To set to Tom Clegg
Actions #2

Updated by Tom Clegg almost 5 years ago

Confirmed the "filter by PDH" part already works. It's inconvenient to test, and not obvious that it's working, just because the PDH isn't shown.

Actions #3

Updated by Tom Morris almost 5 years ago

As we discussed during grooming, let's go with the approach of stacking the two dates to free up space for the PDH. I think it'd be useful to include the UUID as well (although it's often there for collections which don't have names).

So, the columns become:

Name, Date Trashed / To Be Deleted, Owner, UUID / PDH, Files

where the two columns with slashes have the two different types of contents stacked vertically in the same column.

Actions #4

Updated by Tom Clegg almost 5 years ago

Haven't updated tests yet.

How does this look?

12197-show-pdh-in-trash @ 6ac4615d13060a19d8cafbe35b67838e8ead33b0

https://12197.tom.shell.9tee4.arvadosapi.com/trash

Actions #5

Updated by Tom Morris almost 5 years ago

Looks pretty good. Let's get rid of the trash: and delete: labels since they just make the alignment even more raggedy.

I'm of two minds about the date/times. On the one hand I like respecting the user's locale, but on the other having the leading (left-hand) pieces be variable length makes vertical alignment problematic. The example data is best case, but

1:00 PM
12:00 PM

throws the alignment off.

I think I'm inclined to call it good enough with the deletion of the labels.

Actions #6

Updated by Tom Clegg almost 5 years ago

  • Target version changed from 2017-09-13 Sprint to 2017-09-27 Sprint
Actions #7

Updated by Tom Clegg almost 5 years ago

  • Status changed from New to In Progress
Actions #10

Updated by Lucas Di Pentima almost 5 years ago

A couple of minor comments:

  • File apps/workbench/app/views/trash_items/_show_recent_trash.html.erb
    • Line 47: For UI consistency’s sake, should the PDH acronym be included on the column header? Also I’m seeing that we use the phrase “Content address” for the PDH field on the collection view page, do you think something like “PDH (Content address)” would be a good header alternative?
  • File apps/workbench/app/views/trash_items/_show_trash_rows.html.erb
    • Line 28: Would it be convenient to check for object type before asking for the pdh and only showing it when it’s a collection? I’m thinking about the soon to be added projects to the trash feature.
Actions #11

Updated by Tom Clegg almost 5 years ago

Lucas Di Pentima wrote:

something like “PDH (Content address)” would be a good header alternative?

Sure, went with "Content address (PDH)"

Would it be convenient to check for object type before asking for the pdh and only showing it when it’s a collection? I’m thinking about the soon to be added projects to the trash feature.

I think we should stick to the issue at hand, and leave the future stuff for a future branch. Otherwise: the next column has "files" with the same problem, the alternate case wouldn't be testable, etc.

Actions #12

Updated by Anonymous almost 5 years ago

  • Status changed from In Progress to Resolved

Applied in changeset arvados|commit:a6d5c9b5a512e7c4b04e7f73fe2777bd81277602.

Actions

Also available in: Atom PDF