Project

General

Profile

Actions

Bug #12883

closed

[Composer] Chrome silently suppresses window.open() when using "run" button

Added by Peter Amstutz about 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
02/14/2018
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release relationship:
Auto

Subtasks 1 (0 open1 closed)

Task #12964: ReviewClosedLucas Di Pentima02/14/2018

Actions
Actions #1

Updated by Peter Amstutz about 6 years ago

  • Status changed from New to In Progress
Actions #2

Updated by Peter Amstutz about 6 years ago

  • Status changed from In Progress to New
Actions #3

Updated by Peter Amstutz about 6 years ago

  • Assigned To set to Peter Amstutz
Actions #5

Updated by Peter Amstutz about 6 years ago

  • Assigned To changed from Peter Amstutz to Lucas Di Pentima
Actions #6

Updated by Peter Amstutz about 6 years ago

Chrome's policy is to only open popups if the call to window.open() is directly on the call stack of an input event. The problem is, this doesn't play nicely with the deferred execution strategy used everywhere in Composer. One option is to create a modal dialog with a link "click here to go to workbench" link.

Actions #7

Updated by Lucas Di Pentima about 6 years ago

  • Target version changed from 2018-01-17 Sprint to 2018-01-31 Sprint
Actions #8

Updated by Tom Clegg about 6 years ago

Rather than doing an ajax request (or whatever the async procedure is) that opens a Workbench window in its success callback, would it work to immediately open a window that starts the async procedure and then redirects to Workbench on success?

Actions #9

Updated by Peter Amstutz about 6 years ago

  • Assigned To changed from Lucas Di Pentima to Peter Amstutz
Actions #10

Updated by Peter Amstutz about 6 years ago

  • Target version changed from 2018-01-31 Sprint to 2018-02-14 Sprint
Actions #11

Updated by Peter Amstutz about 6 years ago

The workaround here is to provide clickable link in the "execution" panel which opens a new window, so if window.open() is suppressed the user can still easily get to the container request.

Actions #12

Updated by Peter Amstutz about 6 years ago

Change in note-11 was made in commit:cf8b76c9a983de933fc6ffb934d9732c2a2bf0e7

Actions #13

Updated by Peter Amstutz about 6 years ago

  • Status changed from New to Resolved
Actions #14

Updated by Tom Morris over 5 years ago

  • Release set to 17
Actions

Also available in: Atom PDF