Bug #13120

arvados-cwl-runner does not pass --debug flag to RunnerContainer (when running with --submit and --no-wait)

Added by Joshua Randall about 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Crunch
Target version:
Start date:
04/26/2018
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release:
Release relationship:
Auto

Description

I would expect that running `arvados-cwl-runner --debug ...` would result in the debug flag being run on the local arvados-cwl-runner and also passed on to any subordinate arvados-cwl-runner or cwltool instances that are submitted.

This must be because the kwargs in effect at https://github.com/curoverse/arvados/blob/master/sdk/cwl/arvados_cwl/arvcontainer.py#L368 do not include `debug`.

It looks like this is because the invocation of `runnerjob.run()` at https://github.com/curoverse/arvados/blob/24dc417363fad4b80efda414b9d31dad0772bb69/sdk/cwl/arvados_cwl/__init__.py#L466-L468 does not pass a debug keyword in kwargs. A quick fix for this would be to change line 467 of init.py to be:

            runnerjob.run(wait=kwargs.get("wait"), debug=kwargs.get("debug"))

However, I'm not going to PR that as I'm not sure if there are other kwargs that should be passed in this case as well. IMHO, the runner job should get the same arguments when running with `--no-wait` as when run normally.

I think that is happening via the jobiter, down at https://github.com/curoverse/arvados/blob/24dc417363fad4b80efda414b9d31dad0772bb69/sdk/cwl/arvados_cwl/__init__.py#L499

                        runnable.run(**kwargs)

So perhaps the call when `not kwargs.get("wait")` should also just be `runnable.run(**kwargs)`?


Subtasks

Task #13356: Already fixed?ResolvedPeter Amstutz

History

#1 Updated by Tom Morris about 3 years ago

  • Assigned To set to Peter Amstutz
  • Target version set to 2018-04-25 Sprint

#2 Updated by Peter Amstutz almost 3 years ago

  • Target version changed from 2018-04-25 Sprint to 2018-05-09 Sprint

#3 Updated by Peter Amstutz almost 3 years ago

  • Status changed from New to Resolved

Confirmed this is fixed in master.

#4 Updated by Tom Morris over 2 years ago

  • Release set to 13

Also available in: Atom PDF