Project

General

Profile

Actions

Idea #13145

closed

Include container status & exit code in container request response

Added by Tom Morris over 6 years ago. Updated about 6 years ago.

Status:
Duplicate
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
-
Start date:
Due date:
Story points:
-

Description

As a technical user of Arvados using the Python SDK or the `arv` CLI utility, I would like an easy way to find jobs which have succeeded, failed, or are still running.

Currently this involves first filtering the container_requests by and then fetching the containers for those container_requests which pass the initial filter to get additional fields which can be further checked. I would like to be able to do this in a single operation which is efficient both from a lines of code and a number of API calls point of view.

From a user point of view, the jobs/steps are either queued, running, completed successfully, failed, or canceled. I would like a simple way to filter on these states.


Related issues

Related to Arvados - Idea #9425: [API?/Workbench] Search for a link tag value returns linked objectsNewActions
Is duplicate of Arvados - Feature #12917: Support ?include=container_uuid for group contentsResolvedTom CleggActions
Actions #1

Updated by Tom Morris over 6 years ago

  • Project changed from 35 to Arvados
Actions #2

Updated by Tom Morris over 6 years ago

  • Description updated (diff)
Actions #3

Updated by Tom Morris over 6 years ago

  • Parent task deleted (#12910)
Actions #5

Updated by Tom Morris over 6 years ago

  • Related to Idea #9425: [API?/Workbench] Search for a link tag value returns linked objects added
Actions #6

Updated by Tom Morris about 6 years ago

  • Tracker changed from Task to Idea
Actions #7

Updated by Peter Amstutz about 6 years ago

  • Is duplicate of Feature #12917: Support ?include=container_uuid for group contents added
Actions #8

Updated by Tom Morris about 6 years ago

  • Status changed from New to Duplicate
Actions #9

Updated by Tom Morris about 6 years ago

  • Target version deleted (Arvados Future Sprints)
Actions

Also available in: Atom PDF