Project

General

Profile

Actions

Story #13508

closed

Fix postgres search for filenames

Added by Peter Amstutz about 4 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

Searching for filenames with fulltext search produces inconsistent behavior (see #13507). This is because the standard postgres fulltext search parser is not well suited for searching filenames containing punctuation. We need to either need to index filenames for searching differently (stop using fulltext search on manifest text and perform search some other way) or customize the fulltext parser module to better fit our use case.


Related issues

Related to Arvados - Story #14611: [Epic] Site-wide search for text, filenames, dataDuplicate

Actions
Is duplicate of Arvados - Feature #14573: [Spike] [API] Fully functional filename searchResolvedPeter Amstutz

Actions
Actions #1

Updated by Peter Amstutz about 4 years ago

  • Status changed from New to In Progress
Actions #3

Updated by Peter Amstutz about 4 years ago

  • Tracker changed from Feature to Story
  • Subject changed from Custom postgres fulltext parser to Fix postgres search for filenames
  • Description updated (diff)
Actions #4

Updated by Peter Amstutz about 4 years ago

  • Status changed from In Progress to New
Actions #5

Updated by Tom Clegg over 3 years ago

  • Related to Story #14611: [Epic] Site-wide search for text, filenames, data added
Actions #6

Updated by Tom Clegg over 3 years ago

  • Is duplicate of Feature #14573: [Spike] [API] Fully functional filename search added
Actions #7

Updated by Tom Clegg over 3 years ago

  • Status changed from New to Duplicate
Actions #8

Updated by Tom Clegg over 3 years ago

  • Target version deleted (To Be Groomed)
Actions

Also available in: Atom PDF