Project

General

Profile

Actions

Bug #13613

closed

[R SDK] document minimum version of R required (and check at runtime)

Added by Bryan Cosca over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
07/03/2018
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
1.0
Release:
Release relationship:
Auto

Description

test-copy.R

library(ArvadosR)
packageVersion("ArvadosR")
arv <- Arvados$new("api-token-redacted", "e51c5.arvadosapi.com", numRetries = 3)
previous_collection <- Collection$new(arv, "e51c5-4zz18-ko243dg1k5c6hid")
message("accessed previous collection")
previous_collection$getFileListing()
file_to_be_transferred <- previous_collection$get("foo")

bcosc@shell:~$ Rscript test-copy.R
[1] ‘0.0.4’
accessed previous collection
[1] "foo"
Error in trimFromStart(relativePath, "./") :
could not find function "startsWith"
Calls: <Anonymous> -> <Anonymous> -> trimFromStart
Execution halted


Subtasks 1 (0 open1 closed)

Task #13657: ReviewClosedTom Morris07/03/2018

Actions
Actions #1

Updated by Bryan Cosca over 4 years ago

shell.e51c5 has R version 3.2.3 installed, and this should be fixed in 3.3.0

Actions #2

Updated by Tom Morris over 4 years ago

  • Subject changed from R SDK collection$get errors with 'could not find function "startsWith"' to [R SDK] document minimum version of R required (and check at runtime)
  • Assigned To set to Fuad Muhic
  • Target version set to To Be Groomed

The startsWith method was new in R 3.3.0, so our use of it makes that the minimum R version.

We need to document that minimum and check at run time using getRVersion() or R.version$minor to make sure that our minimum is met.

Bioconductor requires the current R release (3.5 today), so that will become the requirement going forward when we're in Bioconductor.

Actions #3

Updated by Tom Morris over 4 years ago

  • Story points set to 1.0
Actions #4

Updated by Tom Morris over 4 years ago

  • Target version changed from To Be Groomed to 2018-07-03 Sprint
Actions #5

Updated by Fuad Muhic over 4 years ago

  • Status changed from New to In Progress

Users running R version less than 3.3.0 (for now) will get a warning message every time they try to load the package. Package will still load, however. I don't think we can prevent package from loading if version is less than required (I'm not sure if that's what we want anyway). You can test this feature by bumping minAllowedRVersion to "3.6.0" in file "sdk/R/R/zzz.R" on line 3. I also added a note in README file.

Actions #6

Updated by Tom Morris over 4 years ago

LGTM

Actions #7

Updated by Fuad Muhic over 4 years ago

  • Status changed from In Progress to Closed
Actions #8

Updated by Tom Morris over 4 years ago

  • Release set to 13
Actions

Also available in: Atom PDF