Project

General

Profile

Actions

Bug #13613

closed

[R SDK] document minimum version of R required (and check at runtime)

Added by Bryan Cosca almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
07/03/2018
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
1.0
Release:
Release relationship:
Auto

Description

test-copy.R

library(ArvadosR)
packageVersion("ArvadosR")
arv <- Arvados$new("api-token-redacted", "e51c5.arvadosapi.com", numRetries = 3)
previous_collection <- Collection$new(arv, "e51c5-4zz18-ko243dg1k5c6hid")
message("accessed previous collection")
previous_collection$getFileListing()
file_to_be_transferred <- previous_collection$get("foo")

bcosc@shell:~$ Rscript test-copy.R
[1] ‘0.0.4’
accessed previous collection
[1] "foo"
Error in trimFromStart(relativePath, "./") :
could not find function "startsWith"
Calls: <Anonymous> -> <Anonymous> -> trimFromStart
Execution halted


Subtasks 1 (0 open1 closed)

Task #13657: ReviewClosedTom Morris07/03/2018

Actions
Actions

Also available in: Atom PDF