Story #13627

Update a-c-r to newest cwltool

Added by Peter Amstutz over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
06/19/2018
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
0.5
Release:
Release relationship:
Auto

Subtasks

Task #13631: Review 13627-update-cwltoolResolvedPeter Amstutz

Task #13665: Review 13627-set-work-api ResolvedLucas Di Pentima

Associated revisions

Revision cc556a86
Added by Peter Amstutz over 2 years ago

Merge branch '13627-update-cwltool' refs #13627

Arvados-DCO-1.1-Signed-off-by: Peter Amstutz <>

Revision e677e6b2 (diff)
Added by Peter Amstutz over 2 years ago

Add mypy-extensions to build.list refs #13627

Arvados-DCO-1.1-Signed-off-by: Peter Amstutz <>

Revision a200bee2
Added by Peter Amstutz over 2 years ago

Merge branch '13627-set-work-api' refs #13627

Arvados-DCO-1.1-Signed-off-by: Peter Amstutz <>

Revision 93661ec7 (diff)
Added by Peter Amstutz over 2 years ago

Add mypy-extensions to build.list refs #13627

Arvados-DCO-1.1-Signed-off-by: Peter Amstutz <>

History

#1 Updated by Peter Amstutz over 2 years ago

  • Status changed from New to In Progress

#2 Updated by Peter Amstutz over 2 years ago

  • Subject changed from Update cwltool to Update a-c-r to newest cwltool

#3 Updated by Peter Amstutz over 2 years ago

13627-update-cwltool @ 3bf756a35827ed8f7e0c18b5496031cdfeb8157e

https://ci.curoverse.com/job/developer-run-tests/757/

Running cwl test suite for crunch v1 / v2 tests in arvbox.

(note to self: run the arvados-specific test suite as well)

#4 Updated by Peter Amstutz over 2 years ago

Yea, found a bug running the arvados-specific tests:

13627-update-cwltool 05fe77ea63bdbd7cc245301d2891f14456f2b5a0

https://ci.curoverse.com/job/developer-run-tests/760/

#6 Updated by Lucas Di Pentima over 2 years ago

Running sdk/cwl tests locally y get this failure:

======================================================================
FAIL: test_run (tests.test_container.TestContainer)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/lucas/tmp/VENVDIR/local/lib/python2.7/site-packages/mock/mock.py", line 1305, in patched
    return func(*args, **keywargs)
  File "/home/lucas/arvados_local/sdk/cwl/tests/test_container.py", line 111, in test_run
    'secret_mounts': {}
  File "/home/lucas/tmp/VENVDIR/local/lib/python2.7/site-packages/mock/mock.py", line 935, in assert_called_with
    if expected != actual:
  File "/home/lucas/tmp/VENVDIR/local/lib/python2.7/site-packages/mock/mock.py", line 2200, in __ne__
    return not self.__eq__(other)
  File "/home/lucas/tmp/VENVDIR/local/lib/python2.7/site-packages/mock/mock.py", line 2196, in __eq__
    return (other_args, other_kwargs) == (self_args, self_kwargs)
  File "/home/lucas/arvados_local/sdk/cwl/tests/matcher.py", line 27, in __eq__
    fromfile="Expected", tofile="Actual")))
AssertionError: *** Expected
--- Actual
***************
*** 19,25 ****
        "kind": "tmp" 
      }
    }, 
!   "name": "test_run_True", 
    "output_path": "/var/spool/cwl", 
    "output_ttl": 0, 
    "owner_uuid": "zzzzz-8i9sb-zzzzzzzzzzzzzzz", 
--- 19,25 ----
        "kind": "tmp" 
      }
    }, 
!   "name": "test_run_True_3", 
    "output_path": "/var/spool/cwl", 
    "output_ttl": 0, 
    "owner_uuid": "zzzzz-8i9sb-zzzzzzzzzzzzzzz", 

----------------------------------------------------------------------

#7 Updated by Lucas Di Pentima over 2 years ago

Conformance tests passed OK on my side.

#8 Updated by Peter Amstutz over 2 years ago

I can't reproduce that error but made a test tweak anyway on a guess. Running here:

https://ci.curoverse.com/job/developer-run-tests/767/

#9 Updated by Lucas Di Pentima over 2 years ago

Tried locally, and they went ok. LGTM, thanks!

#10 Updated by Peter Amstutz over 2 years ago

  • Target version changed from 2018-06-20 Sprint to 2018-07-03 Sprint

#11 Updated by Tom Morris over 2 years ago

  • Tracker changed from Bug to Story
  • Story points set to 0.5

#12 Updated by Peter Amstutz over 2 years ago

  • Status changed from In Progress to Resolved

#13 Updated by Tom Morris about 2 years ago

  • Release set to 13

Also available in: Atom PDF