Bug #13759

crunchstat-summary Error parsing value

Added by Bryan Cosca over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-
Release:
Release relationship:
Auto

Description

I have a custom script for running crunchstat summary (https://github.com/bcosc/arvados-tools/blob/master/get-crunchstat-summary.sh) but I'm pretty sure its not my error:

get-crunchstat-summary.sh e51c5-8i9sb-affisf8w0tnevpx
Error parsing value u'1.1.4' (stat u'started', category u'crunchstat'): ValueError('invalid literal for float(): 1.1.4',)
2018-07-05_16:58:20 e51c5-8i9sb-affisf8w0tnevpx 51617 0 stderr crunchstat: crunchstat 1.1.4 started

2018-07-05_16:58:20 e51c5-8i9sb-affisf8w0tnevpx 51617 0 stderr crunchstat: crunchstat 1.1.4 started

Associated revisions

Revision 04b9d6e9
Added by Peter Amstutz about 1 year ago

Merge branch '12690-12748-crunchstat-summary'

refs #12690
refs #12748
refs #13759

Arvados-DCO-1.1-Signed-off-by: Peter Amstutz <>

History

#1 Updated by Bryan Cosca over 1 year ago

I think this is the version too:

(cs209) bcosc@qr1hi-bcosc-shell.qr1hi-bcosc-shell:~/veritasgenetics3/cwl/myGenomePipe$ crunchstat-summary
^CTraceback (most recent call last):
  File "/home/bcosc/cs209/bin/crunchstat-summary", line 4, in <module>
    __import__('pkg_resources').run_script('crunchstat-summary==0.1.20171208184747', 'crunchstat-summary')
  File "/home/bcosc/cs209/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 719, in run_script
    self.require(requires)[0].run_script(script_name, ns)
  File "/home/bcosc/cs209/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 1504, in run_script
    exec(code, namespace, namespace)
  File "/data-sdc/home/bcosc/cs209/lib/python2.7/site-packages/crunchstat_summary-0.1.20171208184747-py2.7.egg/EGG-INFO/scripts/crunchstat-summary", line 17, in <module>
    cmd.run()
  File "/data-sdc/home/bcosc/cs209/lib/python2.7/site-packages/crunchstat_summary-0.1.20171208184747-py2.7.egg/crunchstat_summary/command.py", line 66, in run
    return self.summer.run()
  File "/data-sdc/home/bcosc/cs209/lib/python2.7/site-packages/crunchstat_summary-0.1.20171208184747-py2.7.egg/crunchstat_summary/summarizer.py", line 74, in run
    self._run(logdata)
  File "/data-sdc/home/bcosc/cs209/lib/python2.7/site-packages/crunchstat_summary-0.1.20171208184747-py2.7.egg/crunchstat_summary/summarizer.py", line 78, in _run
    for line in logdata:
KeyboardInterrupt

#2 Updated by Tom Morris over 1 year ago

  • Target version set to To Be Groomed

#3 Updated by Tom Morris over 1 year ago

  • Assigned To set to Tom Morris
  • Target version changed from To Be Groomed to 2018-09-05 Sprint

#4 Updated by Tom Morris over 1 year ago

  • Target version changed from 2018-09-05 Sprint to 2018-09-19 Sprint

#5 Updated by Tom Morris over 1 year ago

  • Status changed from New to In Progress

I think this was caused by an incompatible change in crunchstat logging, but it came up during review of one of the pending crunchstat-summary branches, so I'll address it there.

#6 Updated by Tom Morris about 1 year ago

  • Target version changed from 2018-09-19 Sprint to 2018-10-03 Sprint

#7 Updated by Peter Amstutz about 1 year ago

  • Assigned To changed from Tom Morris to Peter Amstutz
  • Target version changed from 2018-10-03 Sprint to 2018-10-17 sprint

#8 Updated by Peter Amstutz about 1 year ago

  • Status changed from In Progress to Resolved

#9 Updated by Tom Morris about 1 year ago

  • Release set to 14

Also available in: Atom PDF