Bug #14497

[API][Workbench] Security vulnerability on rack

Added by Lucas Di Pentima about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Story points:
-
Release:
Release relationship:
Auto

Description

There's a security issue on rack versions < 1.6.11

https://nvd.nist.gov/vuln/detail/CVE-2018-16471

Associated revisions

Revision eb0390f2
Added by Lucas Di Pentima about 1 year ago

Merge branch '14497-rack-upgrade'
Closes #14497

Arvados-DCO-1.1-Signed-off-by: Lucas Di Pentima <>

History

#1 Updated by Lucas Di Pentima about 1 year ago

Update on 721fb4f8c - branch 14497-rack-upgrade
Test run: https://ci.curoverse.com/job/developer-run-tests/976/

Upgraded rack to version 1.6.11 on API and Workbench

#2 Updated by Lucas Di Pentima about 1 year ago

Re-running wb integration tests, as they failed on the previous run: https://ci.curoverse.com/job/developer-run-tests-apps-workbench-integration/1001/

#3 Updated by Lucas Di Pentima about 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

#4 Updated by Tom Morris 12 months ago

  • Release set to 14

Also available in: Atom PDF