Bug #14540

[API] Limit number of container lock/unlock cycles

Added by Peter Amstutz 9 months ago. Updated 6 months ago.

Status:
Duplicate
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

An un-runnable container can get stuck in an infinite loop of lock/unlock cycles (the dispatcher takes it, fails to start it, and the returns it to the queue). It should keep track of the number of times it is locked/unlocked and cancel the container if it exceeds a configured limit.


Related issues

Related to Arvados - Bug #14495: [crunch2] include space required to download/unpack docker image in tmp disk requestResolved12/10/2018

Is duplicate of Arvados - Bug #11561: [API] Limit number of lock/unlock cycles for a given containerResolved04/26/2017

Is duplicate of Arvados - Bug #9688: [Crunch2] Limit number of dispatch attempts per containerDuplicate08/02/2016

History

#1 Updated by Peter Amstutz 9 months ago

  • Status changed from New to In Progress

#2 Updated by Peter Amstutz 9 months ago

  • Description updated (diff)
  • Status changed from In Progress to New

#3 Updated by Peter Amstutz 9 months ago

  • Related to Bug #14495: [crunch2] include space required to download/unpack docker image in tmp disk request added

#4 Updated by Lucas Di Pentima 9 months ago

  • Assigned To set to Lucas Di Pentima

#5 Updated by Lucas Di Pentima 9 months ago

  • Assigned To deleted (Lucas Di Pentima)
  • Target version changed from 2018-12-12 Sprint to To Be Groomed

#6 Updated by Tom Morris 8 months ago

  • Related to Bug #9688: [Crunch2] Limit number of dispatch attempts per container added

#7 Updated by Tom Morris 8 months ago

  • Related to Bug #11561: [API] Limit number of lock/unlock cycles for a given container added

#8 Updated by Peter Amstutz 8 months ago

  • Related to deleted (Bug #9688: [Crunch2] Limit number of dispatch attempts per container)

#9 Updated by Peter Amstutz 8 months ago

  • Related to deleted (Bug #11561: [API] Limit number of lock/unlock cycles for a given container)

#10 Updated by Peter Amstutz 8 months ago

  • Is duplicate of Bug #11561: [API] Limit number of lock/unlock cycles for a given container added

#11 Updated by Peter Amstutz 8 months ago

  • Is duplicate of Bug #9688: [Crunch2] Limit number of dispatch attempts per container added

#12 Updated by Peter Amstutz 8 months ago

  • Status changed from New to Duplicate

#13 Updated by Tom Morris 6 months ago

  • Target version deleted (To Be Groomed)

Also available in: Atom PDF