Support #14765

Support question - deploy on baremetal Kubernetes

Added by Alex Gonopolskiy over 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Deployment
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

I am trying to deploy Arvados Kubernetes without a cloud provider (on vms on our local cluster) using https://doc.arvados.org/install/arvados-on-kubernetes.html. I am able to deploy using helm, but after having all the services running I cannot login into the cluster using workbench. I am able to navigate to the workbench login page using the nodePort, but when I try to login, the request times out when it tries to hit the arvados api from outside the cluster using the targetPort 444.

Has anyone encountered this? How can I open up


Related issues

Related to Arvados Epics - Story #16303: Kubernetes supportIn Progress03/01/202209/30/2022

History

#1 Updated by Peter Amstutz over 1 year ago

  • Related to Bug #14872: [Epic] Kubernetes support added

#2 Updated by Peter Amstutz over 1 year ago

#3 Updated by Peter Amstutz over 1 year ago

  • Related to deleted (Bug #14872: [Epic] Kubernetes support)

#4 Updated by Ward Vandewege over 1 year ago

  • Assigned To set to Ward Vandewege
  • Status changed from New to Resolved

Hi Alex,

I suspect the issue you ran into was caused by a missing 'external IP' for your services.

We merged Minikube support yesterday. You will find a script called 'minikube-external-ip.sh' in the charts/arvados/ directory, which sets the external IP for all the services for the Minikube case. You should be able to do the equivalent for bare metal that way.

Please let us know if that doesn't resolve your issue.

Thanks,
Ward.

#5 Updated by Ward Vandewege over 1 year ago

  • Subject changed from Deploy on baremetal Kubernetes to Support question - deploy on baremetal Kubernetes

Also available in: Atom PDF