Project

General

Profile

Actions

Bug #14872

closed

[Epic] Kubernetes support

Added by Peter Amstutz almost 4 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

Support production Arvados install on Kubernetes. This means:

  • Easy installation in supported environments (helm charts or...)
  • Persistent block storage for postgres database, git repos
  • Keep (but maybe still using cloud-specific object store backends)
  • Run job containers on kubernetes, stage input from keep, send output to keep, handle logging
  • Auto-scaling hardware resources to handle jobs (this might be entirely handled for us, or we might need to request resources on demand.)

Related issues

Is duplicate of Arvados Epics - Story #16303: Kubernetes supportIn Progress11/01/202204/30/2023

Actions
Actions #1

Updated by Peter Amstutz almost 4 years ago

  • Status changed from New to In Progress
Actions #2

Updated by Peter Amstutz almost 4 years ago

  • Description updated (diff)
  • Status changed from In Progress to New
Actions #3

Updated by Peter Amstutz over 2 years ago

  • Related to Support #14765: Support question - deploy on baremetal Kubernetes added
Actions #4

Updated by Peter Amstutz over 2 years ago

  • Target version deleted (To Be Groomed)
Actions #5

Updated by Peter Amstutz over 2 years ago

  • Related to deleted (Support #14765: Support question - deploy on baremetal Kubernetes)
Actions #6

Updated by Peter Amstutz over 2 years ago

Actions #7

Updated by Ward Vandewege over 2 years ago

Actions #8

Updated by Ward Vandewege over 2 years ago

  • Blocked by Feature #16385: add prebuilt container images for Arvados releases added
Actions #9

Updated by Ward Vandewege over 2 years ago

  • Related to Feature #16386: [k8s] make the docker images for our golang binaries much leaner added
Actions #10

Updated by Ward Vandewege over 2 years ago

Actions #11

Updated by Ward Vandewege over 2 years ago

  • Related to deleted (Feature #16386: [k8s] make the docker images for our golang binaries much leaner)
Actions #12

Updated by Ward Vandewege over 2 years ago

Actions #13

Updated by Ward Vandewege over 2 years ago

  • Blocked by deleted (Feature #16385: add prebuilt container images for Arvados releases)
Actions #14

Updated by Ward Vandewege over 2 years ago

Actions #15

Updated by Ward Vandewege over 2 years ago

  • Status changed from New to Duplicate

Duplicate of #16303

Actions #16

Updated by Ward Vandewege over 2 years ago

Actions #17

Updated by Ward Vandewege over 2 years ago

Actions #18

Updated by Peter Amstutz about 1 year ago

  • Related to Bug #18278: [k8s] start using an ingress added
Actions #19

Updated by Peter Amstutz about 1 year ago

  • Related to deleted (Bug #18278: [k8s] start using an ingress)
Actions

Also available in: Atom PDF