Story #14946

Update to Ruby 2.5 - 2.3 is going EOL

Added by Tom Morris 4 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
05/31/2019
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
1.0
Release relationship:
Auto

Subtasks

Task #14963: Review 14946-ruby-2.5ResolvedLucas Di Pentima


Related issues

Related to Arvados - Bug #14967: [SSO] fails to start with Ruby 2.4 (future of the SSO server)New

Related to Arvados - Story #14989: [SSO] Upgrade to Rails 5New

Blocked by Arvados - Story #14988: [Workbench] Upgrade to Rails 5Resolved05/14/2019

Blocked by Arvados - Story #14873: [API] Update to Rails 5Resolved03/20/2019

Associated revisions

Revision e7c54238
Added by Lucas Di Pentima about 1 month ago

Merge branch '14946-ruby-2.5'
Refs #14946

Arvados-DCO-1.1-Signed-off-by: Lucas Di Pentima <>

History

#1 Updated by Lucas Di Pentima 4 months ago

  • Assigned To set to Lucas Di Pentima

#2 Updated by Peter Amstutz 4 months ago

I have a branch of arvbox, I just tried upgrading ruby to 2.4. We might have a problem with the SSO server:

2019-03-13_18:21:07.25233 Bundler::GemRequireError: There was an error while trying to load the gem 'devise'.
2019-03-13_18:21:07.25233 Gem Load Error is: ActiveSupport::Duration can't be coerced into Integer
2019-03-13_18:21:07.25233 Backtrace for gem load error is:
2019-03-13_18:21:07.25233 /var/lib/gems/ruby/2.4.0/gems/activesupport-3.2.22.5/lib/active_support/core_ext/numeric/time.rb:50:in `*'
2019-03-13_18:21:07.25233 /var/lib/gems/ruby/2.4.0/gems/activesupport-3.2.22.5/lib/active_support/core_ext/numeric/time.rb:50:in `days'
2019-03-13_18:21:07.25234 /var/lib/gems/ruby/2.4.0/gems/activesupport-3.2.22.5/lib/active_support/core_ext/numeric/time.rb:55:in `weeks'
2019-03-13_18:21:07.25234 /var/lib/gems/ruby/2.4.0/gems/devise-2.2.8/lib/devise.rb:102:in `<module:Devise>'
2019-03-13_18:21:07.25234 /var/lib/gems/ruby/2.4.0/gems/devise-2.2.8/lib/devise.rb:8:in `<top (required)>'
2019-03-13_18:21:07.25234 /var/lib/gems/gems/bundler-1.16.1/lib/bundler/runtime.rb:81:in `require'
2019-03-13_18:21:07.25234 /var/lib/gems/gems/bundler-1.16.1/lib/bundler/runtime.rb:81:in `block (2 levels) in require'
2019-03-13_18:21:07.25234 /var/lib/gems/gems/bundler-1.16.1/lib/bundler/runtime.rb:76:in `each'
2019-03-13_18:21:07.25235 /var/lib/gems/gems/bundler-1.16.1/lib/bundler/runtime.rb:76:in `block in require'
2019-03-13_18:21:07.25235 /var/lib/gems/gems/bundler-1.16.1/lib/bundler/runtime.rb:65:in `each'
2019-03-13_18:21:07.25235 /var/lib/gems/gems/bundler-1.16.1/lib/bundler/runtime.rb:65:in `require'
2019-03-13_18:21:07.25235 /var/lib/gems/gems/bundler-1.16.1/lib/bundler.rb:114:in `require'
2019-03-13_18:21:07.25236 /usr/src/sso/config/application.rb:7:in `<top (required)>'
2019-03-13_18:21:07.25236 /usr/src/sso/Rakefile:4:in `require'
2019-03-13_18:21:07.25236 /usr/src/sso/Rakefile:4:in `<top (required)>'

#3 Updated by Peter Amstutz 4 months ago

  • Related to Bug #14967: [SSO] fails to start with Ruby 2.4 (future of the SSO server) added

#4 Updated by Fernando Monserrat 4 months ago

@lucas @Peter we were talking on our kanban about the ruby update, why don't we try to go to version 2.5 instead of 2.4 . For Debian (buster)and Ubuntu (bionic) default is 2.5.1 and we think stretch will move to this version also now taht 2.3 is in EOL .

#5 Updated by Lucas Di Pentima 4 months ago

  • Status changed from New to In Progress

#6 Updated by Lucas Di Pentima 4 months ago

Fernando: Rails 4.2 doesn't support ruby 2.5, BUT rails 4.2 will be completely unsupported near April 30th when rails 6 is released, so I think it's maybe worth to try to upgrade rails & ruby on the same go.

#7 Updated by Lucas Di Pentima 4 months ago

#8 Updated by Lucas Di Pentima 4 months ago

  • Blocked by Story #14988: [Workbench] Upgrade to Rails 5 added

#9 Updated by Lucas Di Pentima 4 months ago

#10 Updated by Lucas Di Pentima 4 months ago

#11 Updated by Lucas Di Pentima 4 months ago

  • Blocked by deleted (Story #14987: [API] Upgrade to Rails 5)

#12 Updated by Lucas Di Pentima 4 months ago

  • Target version changed from 2019-03-27 Sprint to 2019-04-10 Sprint

#13 Updated by Tom Morris 4 months ago

  • Subject changed from Update to Ruby 2.4 - 2.3 is going EOL to Update to Ruby 2.5 - 2.3 is going EOL

#14 Updated by Lucas Di Pentima 3 months ago

  • Target version changed from 2019-04-10 Sprint to 2019-04-24 Sprint

#15 Updated by Lucas Di Pentima 3 months ago

  • Target version changed from 2019-04-24 Sprint to 2019-05-08 Sprint

#18 Updated by Lucas Di Pentima 3 months ago

  • Target version changed from 2019-05-08 Sprint to 2019-05-22 Sprint

#19 Updated by Lucas Di Pentima 2 months ago

  • Target version changed from 2019-05-22 Sprint to 2019-06-05 Sprint

#20 Updated by Lucas Di Pentima 2 months ago

  • Story points set to 1.0

#21 Updated by Lucas Di Pentima about 2 months ago

Status update: 0a80a91b9 - branch 14946-ruby-2.5

#22 Updated by Lucas Di Pentima about 2 months ago

Fernando just launched a full test run (https://ci.curoverse.com/view/Developer/job/ruby25-run-tests-services-api/9) after confirming WB unit test success.

#23 Updated by Lucas Di Pentima about 2 months ago

Updated SSO's installation documentation to ask for ruby 2.3, while the rest asks for 2.5 - c4107b1da

#24 Updated by Lucas Di Pentima about 2 months ago

Updates at 618643017
Test run: https://ci.curoverse.com/view/Developer/job/ruby25-run-tests-services-api/12

Fixed several warnings regarding un-initialized variables, deprecated Fixnum usage, unused variables, etc.

#25 Updated by Lucas Di Pentima about 2 months ago

Updates at ebce50053
Test run: https://ci.curoverse.com/view/Developer/job/ruby25-run-tests-services-api/14/console

Further ruby warning fixes were made.
There are warnings coming from various gems that we use on workbench, some of them don't have newer versions (for example andand), should we invest time on trying to fix them?

Fernando tells me that we shouldn't merge this without confirming with him first, as he's doing some work on Jenkins to be able to support the newer ruby.

#26 Updated by Tom Clegg about 2 months ago

Lucas Di Pentima wrote:

Updates at ebce50053

LGTM

There are warnings coming from various gems that we use on workbench, some of them don't have newer versions (for example andand), should we invest time on trying to fix them?

I don't think so. The warnings only show up in dev/test mode, not in production, right?

Fernando tells me that we shouldn't merge this without confirming with him first, as he's doing some work on Jenkins to be able to support the newer ruby.

It doesn't seem like this depends on 2.5 so it should work anyway -- but whatever is easier for Fernando sounds good to me.

#27 Updated by Lucas Di Pentima about 2 months ago

  • Target version changed from 2019-06-05 Sprint to 2019-06-19 Sprint

#28 Updated by Ward Vandewege about 1 month ago

  • Release set to 22

#29 Updated by Lucas Di Pentima about 1 month ago

  • Blocked by deleted (Story #14989: [SSO] Upgrade to Rails 5)

#30 Updated by Lucas Di Pentima about 1 month ago

#31 Updated by Lucas Di Pentima about 1 month ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF