Project

General

Profile

Actions

Bug #15058

closed

[SSO] "Not found. Authentication passthru" when using local account authentication

Added by Ward Vandewege over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
04/10/2019
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release relationship:
Auto

Description

The latest SSO server packages (starting in 1.2.1; version 1.2.0 worked) have a bug that prevents them from functioning in the configuration where local accounts are configured. When clicking the 'login to Arvados' button, the user sees:

"Not found. Authentication passthru." 

The logs show

Started GET "/users/auth/local" for 127.0.0.1 at 2019-04-02 14:40:37 +0200
Processing by Users::OmniauthCallbacksController#passthru as HTML
 Parameters: {"provider"=>"local"}
 Rendered text template (0.0ms)
Completed 404 Not Found in 0.3ms (Views: 0.2ms | ActiveRecord: 0.0ms)

Subtasks 1 (0 open1 closed)

Task #15099: Review 15058-local-account-fixesResolvedLucas Di Pentima04/10/2019

Actions

Related issues

Is duplicate of Arvados - Bug #14703: [SSO] Login fails when configured with only the local providerResolvedLucas Di Pentima01/08/2019

Actions
Actions #1

Updated by Ward Vandewege over 3 years ago

  • Subject changed from [SSO] "Not found. Authentication passthru" when using local accounts to [SSO] "Not found. Authentication passthru" when using local account authentication
  • Description updated (diff)
Actions #2

Updated by Ward Vandewege over 3 years ago

  • Description updated (diff)
Actions #3

Updated by Ward Vandewege over 3 years ago

  • Status changed from New to In Progress
  • Assigned To set to Ward Vandewege
  • Target version changed from To Be Groomed to 2019-04-24 Sprint

Fix ready for review in commit:56e700608e6acd3e0d062b90f50969e697e1bc46 on branch 15058-local-account-fixes

Actions #4

Updated by Lucas Di Pentima over 3 years ago

Trying to see which commit introduced the issue between 1.2.0 & current version I realized that #14703 is about the same issue as this bug report, and it's assigned to the 1.4 release (as per redmine) so maybe it was already fixed? I detected the issue when trying to set up a fresh arvbox instance. Since then, I didn't had any more issues with new arvboxes.

Actions #5

Updated by Ward Vandewege over 3 years ago

  • Related to Bug #14703: [SSO] Login fails when configured with only the local provider added
Actions #6

Updated by Ward Vandewege over 3 years ago

  • Related to deleted (Bug #14703: [SSO] Login fails when configured with only the local provider)
Actions #7

Updated by Ward Vandewege over 3 years ago

  • Is duplicate of Bug #14703: [SSO] Login fails when configured with only the local provider added
Actions #8

Updated by Ward Vandewege over 3 years ago

Lucas Di Pentima wrote:

Trying to see which commit introduced the issue between 1.2.0 & current version I realized that #14703 is about the same issue as this bug report, and it's assigned to the 1.4 release (as per redmine) so maybe it was already fixed? I detected the issue when trying to set up a fresh arvbox instance. Since then, I didn't had any more issues with new arvboxes.

Indeed, this is totally a duplicate of #14703, I'm closing this ticket. Sorry for the noise!

Actions #9

Updated by Ward Vandewege over 3 years ago

  • Status changed from In Progress to Resolved
Actions #10

Updated by Tom Morris about 3 years ago

  • Release set to 15
Actions

Also available in: Atom PDF