Story #15147

Replace lists of strings in new config with maps

Added by Peter Amstutz 6 months ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
1.0

Description

We don't want to use arrays of strings in our config file, so update config and components (API server) to use maps to represent unordered sets.


Related issues

Is duplicate of Arvados - Feature #15467: Revisit new config, ordered lists must end in "List" and unordered sets should be turned into mapsResolved07/26/2019

History

#1 Updated by Peter Amstutz 6 months ago

  • Description updated (diff)

#2 Updated by Tom Morris 6 months ago

  • Target version changed from To Be Groomed to Arvados Future Sprints
  • Story points set to 1.0

#3 Updated by Peter Amstutz 3 months ago

  • Is duplicate of Feature #15467: Revisit new config, ordered lists must end in "List" and unordered sets should be turned into maps added

#4 Updated by Peter Amstutz 3 months ago

  • Status changed from New to Duplicate

#5 Updated by Tom Morris 3 months ago

  • Target version deleted (Arvados Future Sprints)

Also available in: Atom PDF