Bug #15176

Update AngularJS to a supported version

Added by Tom Morris 5 months ago. Updated 5 months ago.

Status:
New
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
2.0

Description

AngularJS: 1.3.15 in use. Current version is 1.7.*


Related issues

Related to Arvados - Bug #15177: Internal Server Error: https://workbench.xxx/themes/curoverse/images/etc/passwdNew

History

#1 Updated by Tom Morris 5 months ago

  • Target version set to To Be Groomed

#2 Updated by Eric Biagiotti 5 months ago

https://docs.angularjs.org/guide/migration

We use the angularjs-rails gem, which we may need to fork to get it up to 1.7.* https://github.com/hiravgandhi/angularjs-rails

#3 Updated by Tom Morris 5 months ago

  • Story points set to 2.0

Believed to only be used in the file uploader to add to and create collections.

#4 Updated by Lucas Di Pentima 5 months ago

  • Related to Bug #15177: Internal Server Error: https://workbench.xxx/themes/curoverse/images/etc/passwd added

#5 Updated by Tom Morris 5 months ago

  • Target version changed from To Be Groomed to Arvados Future Sprints

Also available in: Atom PDF