Story #15477

Use email address for Arvados account linking

Added by Tom Morris 3 months ago. Updated about 2 months ago.

Status:
Duplicate
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

For federated configurations it's sometimes desirable to assist users in account linking and duplicate account identification based on their email address.
(even better would be to avoid the concept of a "home cluster" and allow users to log in to the federation as a whole)

Optionally, if configured, look up the user's email address during new account creation and link any duplicate account.


Related issues

Related to Arvados - Story #15107: [controller] Implement native Google login (configurable as an alternative to sso-provider)In Progress

Related to Arvados - Story #15529: [API] [Controller] Share user account database with a group of trusted clustersResolved08/22/2019

Is duplicate of Arvados - Story #15558: [SSO] [API] Identify users by (alternate) email addressesResolved08/22/2019

History

#1 Updated by Tom Morris 3 months ago

  • Description updated (diff)

#3 Updated by Tom Clegg 3 months ago

  • Related to Story #15107: [controller] Implement native Google login (configurable as an alternative to sso-provider) added

#4 Updated by Tom Clegg 2 months ago

  • Related to Story #15529: [API] [Controller] Share user account database with a group of trusted clusters added

#5 Updated by Peter Amstutz about 2 months ago

  • Is duplicate of Story #15558: [SSO] [API] Identify users by (alternate) email addresses added

#6 Updated by Tom Morris about 2 months ago

  • Target version deleted (To Be Groomed)
  • Status changed from New to Duplicate

Also available in: Atom PDF