Project

General

Profile

Actions

Bug #15557

closed

[Process view] Re-run workflow

Added by Lucas Di Pentima over 4 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Workbench2
Target version:
Story points:
2.0

Description

Menu item on the workflow that makes a copy of the container request in the same project (*) in the "uncommitted" state.

notes:

  1. if the project picker supports pre-selecting a project, then it should bring up the project picker with the original project selected.
  2. if the user picks a different project, it should include a note that it doesn't copy dependencies so sharing the project with someone else may not include all the required inputs

Subtasks 1 (0 open1 closed)

Task #19913: Review 15557-rerun-workflowResolvedLucas Di Pentima01/10/2023Actions

Related issues

Related to Arvados Epics - Idea #16945: WB2 Workflows / containers feature parityResolved08/01/202103/31/2023Actions
Related to Arvados - Bug #19898: Container request in "draft" state shows toplevel processes in its subprocess panelResolvedStephen Smith02/13/2023Actions
Is duplicate of Arvados - Feature #18209: Re-run process on arvados throws errorNewActions
Blocks Arvados - Idea #19636: Editing inputs on "draft" tasksNewActions
Actions #1

Updated by Lucas Di Pentima over 4 years ago

  • Category set to Workbench2
  • Target version set to Arvados Future Sprints
Actions #2

Updated by Lucas Di Pentima over 4 years ago

  • Subject changed from [Workbench2] Re-run process doesn't copy the default input values to [workbench2] Run workflow inputs issues
  • Description updated (diff)
Actions #3

Updated by Peter Amstutz over 4 years ago

  • Release set to 20
  • Target version deleted (Arvados Future Sprints)
Actions #4

Updated by Peter Amstutz about 4 years ago

  • Release changed from 20 to 31
Actions #5

Updated by Peter Amstutz about 4 years ago

  • Subject changed from [workbench2] Run workflow inputs issues to [Process view] Run workflow inputs issues
Actions #6

Updated by Peter Amstutz about 3 years ago

  • Related to Idea #16945: WB2 Workflows / containers feature parity added
Actions #7

Updated by Peter Amstutz about 2 years ago

  • Description updated (diff)
  • Subject changed from [Process view] Run workflow inputs issues to [Process view] Re-run workflow
Actions #8

Updated by Peter Amstutz over 1 year ago

  • Is duplicate of Feature #18209: Re-run process on arvados throws error added
Actions #9

Updated by Peter Amstutz over 1 year ago

  • Release deleted (31)
  • Target version set to 2023-02-01 sprint
Actions #10

Updated by Peter Amstutz over 1 year ago

  • Description updated (diff)
Actions #11

Updated by Peter Amstutz over 1 year ago

  • Related to Idea #19636: Editing inputs on "draft" tasks added
Actions #12

Updated by Peter Amstutz over 1 year ago

  • Related to deleted (Idea #19636: Editing inputs on "draft" tasks)
Actions #14

Updated by Peter Amstutz over 1 year ago

  • Blocks Idea #19636: Editing inputs on "draft" tasks added
Actions #16

Updated by Peter Amstutz over 1 year ago

  • Story points set to 2.0
  • Description updated (diff)
Actions #17

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2023-02-01 sprint to 2023-01-18 sprint
Actions #18

Updated by Stephen Smith over 1 year ago

  • Assigned To set to Stephen Smith
Actions #19

Updated by Stephen Smith over 1 year ago

  • Status changed from New to In Progress
Actions #20

Updated by Stephen Smith over 1 year ago

Changes at arvados-workbench2|b114600c55e53b4c16f091edbabdb2ebeba0f032
Tests developer-tests-workbench2: #1054

  • Added start button to process details card for uncommitted/draft processes
  • Remove old re-run context menu item (leads to the 3 step launch workflow form)
  • Rename process copy context menu item to "Copy and re-run process", since the copy action already puts the copied process into draft status
  • I skipped pre-filling the copy destination because the tree picker doesn't seem to display the location when the copy form is initialized with a value
Actions #21

Updated by Peter Amstutz about 1 year ago

  • Related to Bug #19898: Container request in "draft" state shows toplevel processes in its subprocess panel added
Actions #22

Updated by Peter Amstutz about 1 year ago

Stephen Smith wrote in #note-20:

Changes at arvados-workbench2|b114600c55e53b4c16f091edbabdb2ebeba0f032
Tests developer-tests-workbench2: #1054

  • The run button as just a "play button" is a little bit subtle, I didn't notice it at first. I suggest giving Sarah a screenshot and see what she thinks.
  • The "copy" dialog is small and awkward to use. It needs to be resized the same way we did with the file picker.
  • Processes in "draft" state show incorrect contents in the Subprocesses panel, I we should go ahead and fix #19898 on this ticket.
  • I'm looking at src/store/processes/process-copy-actions.ts and I'm not 100% sure the list of fields is correct. From our API docs, here's the fields that should be copied:
    • name
    • description
    • properties
    • container_count_max
    • mounts
    • runtime_constraints
    • scheduling_parameters
    • container_image
    • environment
    • cwd
    • command
    • output_path
    • output_name
    • output_ttl
    • use_existing
    • output_storage_classes
    • output_properties

In addition, state should be "Uncommitted" and priority should be 500.

Actions #23

Updated by Peter Amstutz about 1 year ago

  • Target version changed from 2023-01-18 sprint to 2023-02-01 sprint
Actions #24

Updated by Stephen Smith about 1 year ago

Changes at arvados-workbench2|56529b81cf7b67cfea510652f07e1778cc82922e
Tests developer-tests-workbench2: #1063

  • Fix incorrect subprocesses in subprocess panel
  • Increase default height for tree picker
  • Correct list of copied process properties
    • Adds description, output properties, and output storage classes
    • Removes expires at, filters, and requesting container uuid
  • Set priority to 500 when copying
  • Restyle run button to green contained button with label "Run Process" as suggested by Sarah
Actions #25

Updated by Peter Amstutz about 1 year ago

  • Target version changed from 2023-02-01 sprint to 2023-02-15 sprint
Actions #26

Updated by Lucas Di Pentima about 1 year ago

Some comments:

  • The "RUN PROCESS" button doesn't have its label centered vertically, and being placed besides the "Draft" label makes it more evident.
  • I think the "Copy & re-run process" action should navigate to the newly created process.
  • I believe some additional testing is in order.
    • At least I imagine a unit test that exercises the "copy & re-run" action should be fairly easy (making sure all the correct params are copied, and state & priority correctly passed)
    • Testing that the "Run process" button appears when it should on Cypress would be another idea.
Actions #27

Updated by Stephen Smith about 1 year ago

Changes at arvados-workbench2|79f55f622c5addb5351c9cc4d5976cf936fb7143
Tests developer-tests-workbench2: #1068

  • Navigates to new process after copying
  • Added unit test for copy process to verify which fields are copied
  • Add cypress test that copies a process and checks for run process button
Actions #28

Updated by Lucas Di Pentima about 1 year ago

This LGTM, thanks!

Actions #29

Updated by Stephen Smith about 1 year ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF