Project

General

Profile

Actions

Story #15581

closed

[Workbench2] Improve error handling and reporting

Added by Eric Biagiotti almost 3 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assigned To:
-
Category:
Workbench2
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-
Release relationship:
Auto

Description

Improve error handling and reporting for failed promises/async methods and internal errors by dispatching actions to an single reducer, which maintains error state (i.e. a list of errors, the ability to add/remove/clear errors).


Related issues

Related to Arvados Epics - Story #15333: Workbench2 feature parity with WorkbenchClosed01/01/202012/31/2021

Actions
Related to Arvados Workbench 2 - Story #15603: [Workbench 2] Update Fileupload component to new error reporting & unit test architectureNew

Actions
Related to Arvados - Story #15336: [Workbench2] LoggingClosed

Actions
Blocked by Arvados - Story #15334: [Workbench2] Unit testingResolved

Actions
Blocked by Arvados - Story #15335: [Workbench2] Integration testingResolved

Actions
Actions #1

Updated by Eric Biagiotti almost 3 years ago

  • Related to Story #15333: Workbench2 feature parity with Workbench added
Actions #2

Updated by Tom Morris almost 3 years ago

  • Target version set to To Be Groomed
Actions #3

Updated by Tom Morris almost 3 years ago

Actions #4

Updated by Tom Morris almost 3 years ago

  • Blocked by Story #15335: [Workbench2] Integration testing added
Actions #5

Updated by Tom Morris almost 3 years ago

  • Related to Story #15603: [Workbench 2] Update Fileupload component to new error reporting & unit test architecture added
Actions #6

Updated by Peter Amstutz over 2 years ago

Actions #7

Updated by Peter Amstutz over 2 years ago

  • Is duplicate of deleted (Story #15336: [Workbench2] Logging)
Actions #8

Updated by Peter Amstutz over 2 years ago

Actions #9

Updated by Peter Amstutz over 2 years ago

  • Target version deleted (To Be Groomed)
  • Subject changed from [Workbench2] Improve error handling and reporting to [Workbench2] Improve error handling and reporting
Actions #10

Updated by Peter Amstutz over 2 years ago

  • Release set to 20
Actions #11

Updated by Peter Amstutz about 1 year ago

  • Status changed from New to Resolved
Actions

Also available in: Atom PDF