Bug #15645

[Workbench2] Property Keys are converted into Camel Case Format in Collection View

Added by Moritz Gilsdorf about 1 year ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Assigned To:
Category:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

Observation
When assigning properties keys are converted into camel case format. This means keys like "Study Source" become "studySource" and "Phase" becomes "phase". It seems this issue only applies to the collection view, not the project view

Expected
Properties are stored and displayed as entered and stay like this.

How to reproduce
It requires at least two changes to a collection and a page reload between.
  1. Open a collection view and add any property with a multi word key (e.g. "Study Source")
  2. Refresh the page. The key will change to "studySource" after a moment
  3. Open Chrome Devtools and add another property. Check the API PUT request payload, it will contain the property key in camel case.
  4. Afterwards, the property key is persisted as camel case

Related issues

Is duplicate of Arvados - Bug #15407: [WB2] Property keys on collections are getting translated from snake_case to camelCaseResolved08/19/2019

History

#1 Updated by Tom Morris about 1 year ago

  • Target version set to 2019-10-23 Sprint

#2 Updated by Tom Morris about 1 year ago

  • Related to Bug #15407: [WB2] Property keys on collections are getting translated from snake_case to camelCase added

#3 Updated by Tom Morris about 1 year ago

  • Assigned To set to Lucas Di Pentima

I think that this is a duplicate which is already resolved, but assigning to Lucas to double check when he returns from vacation

#4 Updated by Lucas Di Pentima about 1 year ago

Correct. This is a duplicate of #15407, it should be included on the next release.

#5 Updated by Tom Morris about 1 year ago

  • Status changed from New to Duplicate

#6 Updated by Tom Morris about 1 year ago

  • Related to deleted (Bug #15407: [WB2] Property keys on collections are getting translated from snake_case to camelCase)

#7 Updated by Tom Morris about 1 year ago

  • Is duplicate of Task #15509: Review 15407-camel-casing-fix added

#8 Updated by Tom Morris about 1 year ago

  • Is duplicate of Bug #15407: [WB2] Property keys on collections are getting translated from snake_case to camelCase added

#9 Updated by Tom Morris about 1 year ago

  • Is duplicate of deleted (Task #15509: Review 15407-camel-casing-fix)

Also available in: Atom PDF