Project

General

Profile

Actions

Bug #15655

closed

[CWL] encoding error when printing error log tail

Added by Peter Amstutz over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Eric Biagiotti
Category:
-
Target version:
Start date:
10/09/2019
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release relationship:
Auto

Description

2019-09-23T14:05:07.603414105Z Traceback (most recent call last):
2019-09-23T14:05:07.603414105Z   File "/usr/share/python2.7/dist/python-arvados-cwl-runner/lib/python2.7/site-packages/arvados_cwl/arvcontainer.py", line 342, in done
2019-09-23T14:05:07.603414105Z     "%s (%s) error log:" % (label, record["uuid"]), maxlen=40)
2019-09-23T14:05:07.603414105Z   File "/usr/share/python2.7/dist/python-arvados-cwl-runner/lib/python2.7/site-packages/arvados_cwl/done.py", line 74, in logtail
2019-09-23T14:05:07.603414105Z     for l in f:
2019-09-23T14:05:07.603414105Z   File "/usr/share/python2.7/dist/python-arvados-cwl-runner/lib/python2.7/encodings/ascii.py", line 26, in decode
2019-09-23T14:05:07.603414105Z     return codecs.ascii_decode(input, self.errors)[0]
2019-09-23T14:05:07.603414105Z UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 173: ordinal not in range(128)

The log in question has non-ascii characters, so this seems to be an arvados-cwl-runner encoding bug.


Files

15655-unicode-log-fail.cwl (257 Bytes) 15655-unicode-log-fail.cwl Eric Biagiotti, 10/09/2019 12:25 PM

Subtasks 1 (0 open1 closed)

Task #15664: Review 15655-logtail-encodingResolvedPeter Amstutz10/09/2019

Actions

Related issues

Related to Arvados - Bug #15358: [cwl] CWL conformance test formattest2 fails with C localeResolvedPeter Amstutz07/03/2019

Actions
Actions #1

Updated by Peter Amstutz over 4 years ago

  • Description updated (diff)
Actions #2

Updated by Peter Amstutz over 4 years ago

  • Target version changed from 2019-09-25 Sprint to 2019-10-09 Sprint
Actions #3

Updated by Tom Morris over 4 years ago

  • Assigned To set to Eric Biagiotti
Actions #4

Updated by Peter Amstutz over 4 years ago

May be related to (or even fixed by) #15358

Actions #5

Updated by Peter Amstutz over 4 years ago

  • Related to Bug #15358: [cwl] CWL conformance test formattest2 fails with C locale added
Actions #6

Updated by Eric Biagiotti over 4 years ago

  • Status changed from New to In Progress
Actions #7

Updated by Eric Biagiotti over 4 years ago

Reproducible with the attached cwl:

$ export LANG=C
$ arvados-cwl-runner 15655-unicode-log-fail.cwl 

Fixed at fbaa689841e77e152567775d64aaab743dbcdaf0

Tests: https://ci.curoverse.com/view/Developer/job/developer-run-tests/1580/
Conformance: https://ci.curoverse.com/view/CWL/job/arvados-cwl-conformance-tests/257/

Actions #8

Updated by Peter Amstutz over 4 years ago

Actions #9

Updated by Eric Biagiotti over 4 years ago

  • Status changed from In Progress to Resolved
  • Release set to 27
Actions

Also available in: Atom PDF