Arvbox doesn't start because of ruby >= 2.4 requirements on api server
signet-0.12.0 is asking for a newer ruby version.
2019-10-21_19:45:41.48632 + flock /var/lib/gems/gems.lock bundler install --path /var/lib/gems --no-deployment --frozen --without=development 2019-10-21_19:45:51.82321 Fetching gem metadata from https://rubygems.org/....... 2019-10-21_19:45:59.24406 signet-0.12.0 requires ruby version >= 2.4.0, which is incompatible with the 2019-10-21_19:45:59.24408 current version, ruby 2.3.5p376
#2 Updated by Lucas Di Pentima 9 months ago
arvados-google-api-client gem has a dependency on
googleauth (~> 0.3), so the new
googleauth 0.10.0 (instead of 0.8.0) which asks for
signet (~> 0.12), which asks for
ruby >= 2.4.0.
Our documentation (on master) states that the API server is known to work with ruby 2.3, so we either also update the documentation and drop ruby 2.3 support, or pin the requirement on
googleauth to 0.8.0