Bug #15739

Arvbox doesn't start because of ruby >= 2.4 requirements on api server

Added by Lucas Di Pentima 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

Gem signet-0.12.0 is asking for a newer ruby version.

2019-10-21_19:45:41.48632 + flock /var/lib/gems/gems.lock bundler install --path /var/lib/gems --no-deployment --frozen --without=development
2019-10-21_19:45:51.82321 Fetching gem metadata from https://rubygems.org/.......
2019-10-21_19:45:59.24406 signet-0.12.0 requires ruby version >= 2.4.0, which is incompatible with the
2019-10-21_19:45:59.24408 current version, ruby 2.3.5p376

Related issues

Related to Arvados - Bug #16049: [Arvbox] New arvbox instance unable to start because of signet dependency issue on sdk/cliDuplicate01/19/2020

History

#1 Updated by Lucas Di Pentima 6 months ago

  • Description updated (diff)

#2 Updated by Lucas Di Pentima 6 months ago

The arvados-google-api-client gem has a dependency on googleauth (~> 0.3), so the new Gemfile.lock asked googleauth 0.10.0 (instead of 0.8.0) which asks for signet (~> 0.12), which asks for ruby >= 2.4.0.
Our documentation (on master) states that the API server is known to work with ruby 2.3, so we either also update the documentation and drop ruby 2.3 support, or pin the requirement on googleauth to 0.8.0

#3 Updated by Lucas Di Pentima 6 months ago

  • Status changed from In Progress to Resolved

This issue is fixed on #15699

#5 Updated by Lucas Di Pentima 3 months ago

  • Related to Bug #16049: [Arvbox] New arvbox instance unable to start because of signet dependency issue on sdk/cli added

Also available in: Atom PDF