Project

General

Profile

Actions

Story #15856

closed

[WB2] Warn user when viewing a project / collection containing illegal characters

Added by Tom Morris about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
12/02/2019
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-

Description

If a project name or collection name contains a slash (/) or is the string "." or ".." warn the user that this is incompatible with WebDAV clients.

UI affordance is a small red "!" icon with hover text containing the error message.


Subtasks 1 (0 open1 closed)

Task #15857: Review 15856-illegal-chars-warningResolvedEric Biagiotti12/02/2019

Actions
Actions #1

Updated by Tom Morris about 3 years ago

  • Subject changed from Warn user when viewing a project / collection containing illegal characters to [WB2] Warn user when viewing a project / collection containing illegal characters
Actions #2

Updated by Lucas Di Pentima about 3 years ago

  • Assigned To set to Lucas Di Pentima
Actions #3

Updated by Lucas Di Pentima about 3 years ago

  • Status changed from New to In Progress
Actions #4

Updated by Lucas Di Pentima about 3 years ago

Updates at commit:8378a7a9 - branch 15856-illegal-chars-warning

  • Places a red (!) icon (new component) on different places when a collection or project name includes a / character or is '.' or '..', with a tooltip explaining the user what the issue is:
    • Side panel: Projects tree.
    • Breadcrumbs.
    • Collection panel: Name header.
    • Project data explorer table.
  • Removes unused code.
  • Unifies tree picker code.
  • Fixes error handling on collection update dialog.
  • Renames error constant from UNIQUE_VIOLATION (??) to UNIQUE_NAME_VIOLATION.

Pending: I've discovered a bug that I haven't been able to fix yet but it doesn't block this story. When trying to rename a collection, wb2 sends an invalid data key menu_kind to the API server, I'm not sure why typescript allows this yet.

Actions #5

Updated by Eric Biagiotti about 3 years ago

Lucas Di Pentima wrote:

Updates at commit:8378a7a9 - branch 15856-illegal-chars-warning

  • Places a red (!) icon (new component) on different places when a collection or project name includes a / character or is '.' or '..', with a tooltip explaining the user what the issue is:
    • Side panel: Projects tree.
    • Breadcrumbs.
    • Collection panel: Name header.
    • Project data explorer table.
  • Removes unused code.
  • Unifies tree picker code.
  • Fixes error handling on collection update dialog.
  • Renames error constant from UNIQUE_VIOLATION (??) to UNIQUE_NAME_VIOLATION.

Pending: I've discovered a bug that I haven't been able to fix yet but it doesn't block this story. When trying to rename a collection, wb2 sends an invalid data key menu_kind to the API server, I'm not sure why typescript allows this yet.

Nit: I would prefer the warning icon at the end of the text instead of the beginning, but that is really just a preference and is up to you.

Other than that, this works great and LGTM!

Side note, I am able to rename collections fine via clicking on "Actions->Edit collections"

Actions #6

Updated by Lucas Di Pentima about 3 years ago

From chat: Projects/Collections create/edit dialogs need their validations to be updated to not allow illegal naming.

Actions #7

Updated by Lucas Di Pentima about 3 years ago

Update at commit:435d259b

  • Adds name validation to create & edit dialogs.
Actions #8

Updated by Lucas Di Pentima about 3 years ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF