Bug #15907

Downloading 25GB file error

Added by Krzysztof Majewski over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

Downloading 25GB file "SA" from collection: "" causes following exception:
Exception in thread "main" org.arvados.client.exception.ArvadosApiException: java.io.IOException: Cannot buffer entire body for content length: 25106762739
at org.arvados.client.api.client.BaseApiClient.getResponseBody(BaseApiClient.java:74)
at org.arvados.client.api.client.BaseApiClient.newFileCall(BaseApiClient.java:51)
at org.arvados.client.api.client.KeepWebApiClient.download(KeepWebApiClient.java:26)
at org.arvados.client.logic.keep.FileDownloader.downloadSingleFileUsingKeepWeb(FileDownloader.java:66)
at org.arvados.client.facade.ArvadosFacade.downloadFile(ArvadosFacade.java:80)
at org.arvados.client.Test.main(Test.java:37)
Caused by: java.io.IOException: Cannot buffer entire body for content length: 25106762739


Related issues

Related to Arvados - Bug #15919: [Java SDK] Merge PR #107 from githubResolved

History

#1 Updated by Krzysztof Majewski over 2 years ago

EDIT: same thing happens for a 3GB file

#2 Updated by Ward Vandewege over 2 years ago

  • Target version set to To Be Groomed

#3 Updated by Peter Amstutz over 2 years ago

  • Related to Bug #15919: [Java SDK] Merge PR #107 from github added

#4 Updated by Peter Amstutz over 2 years ago

  • Status changed from New to Resolved

Fixed in #15919

#5 Updated by Peter Amstutz over 2 years ago

  • Target version deleted (To Be Groomed)

Also available in: Atom PDF