Bug #15916

[controller] POST /arvados/v1/collections/ (with extra trailing slash) returns 404

Added by Peter Amstutz 7 months ago. Updated 7 months ago.

Status:
Rejected
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

Attempting to create a collection by POST to /arvados/v1/collections/ responds with a 404 with {"errors":["API endpoint not found"]}

Can be reproduced by attempting to upload a file on workbench2.c97qk.arvadosapi.com


Related issues

Related to Arvados - Bug #15921: [Workbench2] Remove spurious trailing slash from API endpointsResolved12/10/2019

History

#1 Updated by Peter Amstutz 7 months ago

  • Status changed from New to In Progress

#2 Updated by Peter Amstutz 7 months ago

  • Description updated (diff)
  • Status changed from In Progress to New

#3 Updated by Tom Clegg 7 months ago

Should this be treated as a workbench2 bug? I don't think we advertise or document such an endpoint (with a trailing slash) anywhere -- it seems like a workbench2 error that used to be magically fixed by Rails.

#4 Updated by Peter Amstutz 7 months ago

Tom Clegg wrote:

Should this be treated as a workbench2 bug? I don't think we advertise or document such an endpoint (with a trailing slash) anywhere -- it seems like a workbench2 error that used to be magically fixed by Rails.

Personally I think controller should accept it and strip the trailing slash, since we don't know what else out there could be relying on this behavior. Otherwise we have to review all the client code to verify that it doesn't happen anywhere else.

#5 Updated by Tom Clegg 7 months ago

  • Related to Bug #15921: [Workbench2] Remove spurious trailing slash from API endpoints added

#6 Updated by Tom Clegg 7 months ago

  • Subject changed from [controller] Can't create collection with EnableBetaController14287: true to [controller] POST /arvados/v1/collections/ (with extra trailing slash) returns 404

#7 Updated by Peter Amstutz 7 months ago

  • Status changed from New to Rejected

Also available in: Atom PDF