Bug #16221

arv-mount 2.0.1 reported not backwards compatible with 1.4

Added by Peter Amstutz 9 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
FUSE
Target version:
Start date:
03/12/2020
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release relationship:
Auto

Description

User report:

Some of our automated build machines pull in the latest version of python-arvados-fuse and python-arvados-python-client when they build themselves, which means they're now getting 2.0.1-1 versions of these packages. When we use this version of arv-mount with our cluster the mount appears to work as expected, but any attempt to actually list a collection just leads to an empty directory.

This was intended to work so I'm not sure if this was a oversight in testing or a mistake in cherry-picking into the release branch.


Subtasks

Task #16237: Review 16221-arv-mount-api-1.xResolvedTom Clegg

Associated revisions

Revision afa7971d
Added by Tom Clegg 9 months ago

Merge branch '16221-arv-mount-api-1.x'

fixes #16221

Arvados-DCO-1.1-Signed-off-by: Tom Clegg <>

History

#1 Updated by Peter Amstutz 9 months ago

  • Description updated (diff)

#2 Updated by Peter Amstutz 9 months ago

  • Assigned To set to Tom Clegg

#3 Updated by Tom Clegg 9 months ago

  • Status changed from New to In Progress

#4 Updated by Lucas Di Pentima 9 months ago

Ok, I was finally able to test arv-mount against a 1.4 arvbox instance and it works correctly.

This LGTM, thanks!

#5 Updated by Tom Clegg 9 months ago

  • Release set to 30

#6 Updated by Anonymous 9 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF