Bug #16377

Workflow fails when keep references in `defaults` are inaccessible even if not used by actual workflow.

Added by Peter Amstutz 9 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
CWL
Target version:
Start date:
07/13/2020
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release relationship:
Auto

Subtasks

Task #16549: Review 16377-missing-defaultResolvedPeter Amstutz

Associated revisions

Revision 7d7b9f9f
Added by Peter Amstutz 6 months ago

Merge branch '16377-missing-default' refs #16377

Arvados-DCO-1.1-Signed-off-by: Peter Amstutz <>

History

#1 Updated by Peter Amstutz 8 months ago

  • Target version changed from 2020-06-03 Sprint to 2020-06-17 Sprint

#2 Updated by Peter Amstutz 8 months ago

  • Target version changed from 2020-06-17 Sprint to 2020-07-01 Sprint

#3 Updated by Peter Amstutz 7 months ago

  • Assigned To set to Peter Amstutz

#4 Updated by Peter Amstutz 7 months ago

  • Category set to CWL

#5 Updated by Peter Amstutz 7 months ago

  • Status changed from New to In Progress

#6 Updated by Peter Amstutz 7 months ago

  • Target version changed from 2020-07-01 Sprint to 2020-07-15

#7 Updated by Peter Amstutz 7 months ago

16377-missing-default @ 9c5923ce6ac1aa71d9a5ea72b4daffa129eef30b

https://ci.arvados.org/view/Developer/job/developer-run-tests/1954/

It turns out this was already supposed to be handled, the bug was that exists() wasn't catching IOError(ENOENT) and turning it into "return False" as intended.

#10 Updated by Peter Amstutz 6 months ago

  • Target version changed from 2020-07-15 to 2020-08-12 Sprint

#11 Updated by Lucas Di Pentima 6 months ago

The fix looks good, but just in case, I dropped the fix, and rebased the tests to current master on a new branch, so I could run them on and see them fail. (ff0886642 - branch: 16377-test-check)
They didn't fail: https://ci.arvados.org/job/developer-run-tests-remainder/2045/

#12 Updated by Peter Amstutz 6 months ago

  • Status changed from In Progress to Resolved

#13 Updated by Peter Amstutz 4 months ago

  • Release set to 25

Also available in: Atom PDF