Bug #16439

New projects/collections sometimes added to the wrong place

Added by Peter Amstutz 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Workbench2
Target version:
Start date:
05/29/2020
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release relationship:
Auto

Description

In workbench 2, sometimes the "New collection" or "New project" button puts the collection or project in an unexpected place. This is either a bug or very bad, confusing UI design.

Reported by customer:

Can be easily reproduced by creating a new collection inside a "Shared with me" project. The same effect for projects.

Related: when a new project or collection is created, Workbench 2 should have an option (or by default?) take you inside the newly created project/collection.

collection dialog.png (165 KB) collection dialog.png Peter Amstutz, 05/29/2020 03:49 PM
dialog-after.png (36.5 KB) dialog-after.png Lucas Di Pentima, 05/29/2020 09:26 PM
dialog-before.png (39 KB) dialog-before.png Lucas Di Pentima, 05/29/2020 09:26 PM

Subtasks

Task #16455: Review 16439-objects-creation-placement-fixResolvedPeter Amstutz

Task #16489: Review 16439-objects-creation-placement-fix-testsNew

Associated revisions

Revision c44f9aa1
Added by Lucas Di Pentima 2 months ago

Merge branch '16439-objects-creation-placement-fix'
Refs #16439

Arvados-DCO-1.1-Signed-off-by: Lucas Di Pentima <>

Revision efcea950
Added by Lucas Di Pentima 2 months ago

Merge branch '16439-objects-creation-placement-fix-tests'
Closes #16439

Arvados-DCO-1.1-Signed-off-by: Lucas Di Pentima <>

History

#1 Updated by Peter Amstutz 3 months ago

  • Description updated (diff)

#2 Updated by Peter Amstutz 3 months ago

  • Description updated (diff)

#3 Updated by Lucas Di Pentima 3 months ago

  • Assigned To set to Lucas Di Pentima

#4 Updated by Lucas Di Pentima 3 months ago

  • Status changed from New to In Progress

#5 Updated by Lucas Di Pentima 2 months ago

  • Release set to 33

#6 Updated by Lucas Di Pentima 2 months ago

Updates at arvados-workbench2|2d04921e - branch 16439-objects-creation-placement-fix
Test run: https://ci.arvados.org/view/Developer/job/developer-tests-workbench2/38/

  • On project/collection creation, auto-navigate to the newly created resource.
  • Allow empty collection (no files) creation.
  • On project/collection creation dialogs, show a read only field with the information where the resource will be placed ('Home project', or 'Project <name+uuid>')

#7 Updated by Peter Amstutz 2 months ago

The "Location" form entry pushes the "Create a collection" button offscreen for me. See screenshot. The whole layout has way too much empty space but the quick fix is probably to shrink the drag and drop target so the button is visible.

Instead of "Location" maybe label it "Parent project" ?

When you hit "New" and with a "shared with me" folder selected, it seems like it always puts it in the home project? I don't think that's the right behavior. If the folder is read-only, "New" should be disabled or give an error, and if the folder is writable I should be able to create things in it. (I think this is the bug they actually wanted fixed?)

#8 Updated by Lucas Di Pentima 2 months ago

From chat:

  • The "+ NEW" button should be disabled when the user's view a non writable folder.
  • Make sure the "Run a process" option creates a CR on the desired project.
  • Try to make the "files" box's height on the create collection dialog to be dynamic, avoiding a vertical scroll bar on the dialog.

#9 Updated by Peter Amstutz 2 months ago

Lucas Di Pentima wrote:

From chat:

  • The "+ NEW" button should be disabled when the user's view a non writable folder.

Just to clarify:

The "+ NEW" button should be disabled when the user's view is not a writable folder.

(To put it another way, the NEW button is only enabled when the user's view is a writable folder.)

#10 Updated by Lucas Di Pentima 2 months ago

After some fiddling I've been able to vertically compress the elements of the create collection dialog so that the "files box" doesn't have to have its height reduced. This is because when uploading files with it, it renders a table with rows too tall that would not show much if I reduce its total height, so I think reducing the empty space between elements is better.

#11 Updated by Lucas Di Pentima 2 months ago

Updates at arvados-workbench2|4dc0af70
Test run: https://ci.arvados.org/view/Developer/job/developer-tests-workbench2/39/

  • Changes "Location" label with "Parent project" as requested.
  • Reduces vertical spacing on form fields to avoid action buttons go outside the dialog viewport.
  • Makes the +NEW button (SidePanelButton component) to only be enabled (aka: clickable) when the user's view is a writable project.
  • Confirmed that running a process places the CR on the current writable project.

#12 Updated by Peter Amstutz 2 months ago

Everything looks great, there's just one issue left. If I try to create something in a "Shared with me" project, it goes to Home instead of the project I have selected.

Steps to reproduce:

1) Create two users
2) Log in with user 1, create a project called "shared project" and share it can_write with user 2
3) Log in as user 2. The "shared project" will appear under "shared with me"
4) Click on "shared project" so it is selected in the UI / displayed in the main panel
5) Click on "New"
6) The dialog field "Parent project" will say "Home project" instead of "shared project" like I expect, and indeed that's where it goes.

Expected behavior: since I had "shared project" selected, and it is writable by me, a new collection or subproject should be added there, not to home.

#13 Updated by Lucas Di Pentima 2 months ago

Updates at arvados-workbench2|0cfd92cc
Test run: https://ci.arvados.org/view/Developer/job/developer-tests-workbench2/40/

  • Fixes parent project placement when using the +NEW button outside the "projects" side panel section.
  • Disables the +NEW button even when navigating deep into the trashed subproject hierarchies.

#14 Updated by Lucas Di Pentima 2 months ago

  • Target version changed from 2020-06-03 Sprint to 2020-06-17 Sprint

#15 Updated by Lucas Di Pentima 2 months ago

Merged 16439-objects-creation-placement-fix at arvados-workbench2|0cfd92c to master so that the 2.0.3 release can be started.

Continuing with test writing on branch 16439-objects-creation-placement-fix-tests

#16 Updated by Lucas Di Pentima 2 months ago

Updates at arvados-workbench2|662c6eec - branch 16439-objects-creation-placement-fix-tests
Test run: https://ci.arvados.org/view/Developer/job/developer-tests-workbench2/42/

Adds several end-to-end tests checking the side panel +NEW button behavior & the collection and project create dialogs.

#17 Updated by Anonymous 2 months ago

  • % Done changed from 50 to 100
  • Status changed from In Progress to Resolved

Also available in: Atom PDF