Bug #16582

[Workbench2] Dockerfile installs golang 1.11 but we need 1.13+

Added by Nico César over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Workbench
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Story points:
-
Release relationship:
Auto

Description

How to reproduce the problem:

  git clone git@git.arvados.org:arvados-workbench2.git
  cd arvados-workbench2/
  cd docker
  docker build .
go: finding github.com/prometheus/procfs v0.0.0-20181005140218-185b4288413d
go: finding github.com/AdRoll/goamz v0.0.0-20170825154802-2731d20f46f4
# git.arvados.org/arvados.git/sdk/go/arvados
sdk/go/arvados/keep_service.go:155:14: undefined: http.NewRequestWithContext
note: module requires Go 1.13The command '/bin/sh -c git clone https://git.arvados.org/arvados.git && cd arvados &&     go mod download &&     go run ./cmd/arvados-server install -type test && cd .. &&     rm -rf arvados &&     apt-get clean' returned a non-zero code: 2

The 2 options that I see:

1) We install golang 1.14 from backports https://packages.debian.org/buster-backports/golang
2) we manually do:

cd /tmp

wget --progress=dot:giga -O- https://storage.googleapis.com/golang/go`+goversion+`.linux-amd64.tar.gz | tar -C /var/lib/arvados -xzf -

ln -sf /var/lib/arvados/go/bin/* /usr/local/bin/

Associated revisions

Revision 6cab974c
Added by Nico Cesar over 1 year ago

Merge branch '16582-dockerfile-go114'
Closes #16582

Arvados-DCO-1.1-Signed-off-by: Nico Cesar <>

History

#1 Updated by Nico César over 1 year ago

  • Target version set to 2020-07-15
  • Assigned To set to Nico César
  • Category set to Workbench
  • Description updated (diff)
  • Subject changed from [Workbench2 to [Workbench2] Dockerfile installs golang 1.11 but we need 1.13+

#2 Updated by Nico César over 1 year ago

I made a fix in commit:71b216012321d1f76b226ab20327bf6b5d49c40f

`docker build .` worked, but I noticed this at the end:

+ ln -sf /var/lib/arvados/gradle-5.3.1/bin/gradle /usr/local/bin/
+ rm /var/lib/arvados/tmp/gradle-5.3.1-bin.zip
+ sed -i 's/^# *\(en_US.UTF-8\)/\1/' /etc/locale.gen
+ locale-gen
Generating locales (this might take a while)...
  en_US.UTF-8... done
Generation complete.
time="2020-07-01T17:36:45.994833434Z" level=info msg="postgresql cluster 11-main is down; trying to start" 
2020-07-01 17:36:46.036 UTC [24831] LOG:  listening on IPv4 address "127.0.0.1", port 5432
2020-07-01 17:36:46.036 UTC [24831] LOG:  could not bind IPv6 address "::1": Cannot assign requested address
2020-07-01 17:36:46.036 UTC [24831] HINT:  Is another postmaster already running on port 5432? If not, wait a few seconds and retry.
2020-07-01 17:36:46.041 UTC [24831] LOG:  listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432" 
2020-07-01 17:36:46.065 UTC [24834] LOG:  database system was shut down at 2020-07-01 17:33:15 UTC
2020-07-01 17:36:46.069 UTC [24831] LOG:  database system is ready to accept connections
2020-07-01 17:36:47.053 UTC [24842] root@root FATAL:  role "root" does not exist
+ sudo systemctl restart postgresql
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to connect to bus: Host is down
time="2020-07-01T17:36:47.226990181Z" level=warning msg="`systemctl restart postgresql` failed; hoping postgresql does not need to be restarted" 
CREATE COLLATION
CREATE COLLATION
2020-07-01 17:36:47.329 UTC [24895] postgres@postgres ERROR:  role "arvados" does not exist
2020-07-01 17:36:47.329 UTC [24895] postgres@postgres STATEMENT:  ALTER ROLE arvados WITH LOGIN SUPERUSER ENCRYPTED PASSWORD 'insecure_arvados_test'
CREATE ROLE
time="2020-07-01T17:36:47.364306123Z" level=info msg="sent SIGTERM; waiting for postgres to shut down" 
2020-07-01 17:36:47.364 UTC [24831] LOG:  received smart shutdown request
2020-07-01 17:36:47.378 UTC [24831] LOG:  background worker "logical replication launcher" (PID 24840) exited with exit code 1
2020-07-01 17:36:47.379 UTC [24835] LOG:  shutting down
2020-07-01 17:36:47.402 UTC [24831] LOG:  database system is shut down
Removing intermediate container 240d51c4b3ac
 ---> 105fdbc3ed0d
Successfully built 105fdbc3ed0d

is that ok?

#3 Updated by Ward Vandewege over 1 year ago

Nico César wrote:

I made a fix in commit:71b216012321d1f76b226ab20327bf6b5d49c40f

`docker build .` worked, but I noticed this at the end:

[...]

is that ok?

Yeah I think it's just noise. I pushed one more commit (commit:f3863df1c40a09e092f6caf53e43324e0477bb5d) on this branch to update the MAINTAINER, LGTM with that change.

#4 Updated by Anonymous over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from New to Resolved

#5 Updated by Peter Amstutz about 1 year ago

  • Release set to 25

Also available in: Atom PDF