Bug #16832

replace linkchecker in our build environment

Added by Ward Vandewege about 1 month ago. Updated 1 day ago.

Status:
New
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

It's Python 2 only, and appears unmaintained upstream.

When done, make sure to update

lib/install/deps.go

so that

arvados-server install -type test

keeps doing the right thing.


Related issues

Related to Arvados Epics - Story #14532: [Epic] Port to Python 3 to for Python 2 sunset in December 2019Resolved01/01/202009/16/2020

History

#1 Updated by Ward Vandewege about 1 month ago

  • Related to Story #14532: [Epic] Port to Python 3 to for Python 2 sunset in December 2019 added

#2 Updated by Peter Amstutz about 1 month ago

  • Target version set to 2020-10-07 Sprint
  • Project changed from Arvados Epics to Arvados

#3 Updated by Ward Vandewege about 1 month ago

Looks like there is at least some action upstream to release version 10.0, which supports Python3:

https://github.com/linkchecker/linkchecker/issues/359

If they managed to push that to pypi, we could simply update the install_env() function in run_tests.sh (a la #16833), remove the linkchecker package from func RunCommand in lib/install/deps.go, and call this story a day. I suppose we could even use the pip3 install line they suggest directly from github, but it seems that could lead to future instability.

#4 Updated by Peter Amstutz 29 days ago

  • Assigned To set to Ward Vandewege

#5 Updated by Peter Amstutz 22 days ago

  • Target version changed from 2020-10-07 Sprint to 2020-10-21 Sprint

#6 Updated by Peter Amstutz 6 days ago

  • Target version changed from 2020-10-21 Sprint to 2020-11-04 Sprint

#7 Updated by Peter Amstutz 1 day ago

  • Target version changed from 2020-11-04 Sprint to 2020-11-18

Also available in: Atom PDF