Support #16861

Determine minimum version of Ruby we support

Added by Peter Amstutz about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
09/22/2020
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release relationship:
Auto

Description

Is the minimum version of Ruby we support in Arvados 2.1 going to be ruby 2.3 or ruby 2.5?

Our package build and test pipeline uses Ruby 2.5 from rvm. The last component that was testing with Ruby 2.3 was arvbox, but that's being moved to ruby 2.5. We can only support Ruby 2.3 if there's something in the jenkins pipeline that checks that it actually works.

Debian 10 and Ubuntu 18.04 have Ruby 2.5, so we can continue to recommend installing from packages.

Debian 9 and Ubuntu 16.04 have 2.3. If we require 2.5, the docs need to direct people to use rvm.


Subtasks

Task #16868: Say we don't support Ruby 2.3 must use 2.5ResolvedWard Vandewege

Associated revisions

Revision ee50db7b (diff)
Added by Ward Vandewege about 1 year ago

Update our docs to state a minimum requirement of Ruby 2.5, since we
don't test on 2.3 anymore.

closes #16868
refs #16861

Arvados-DCO-1.1-Signed-off-by: Ward Vandewege <>

Revision 53c3b64c (diff)
Added by Peter Amstutz about 1 year ago

Tweak text saying which version of Ruby to install & add upgrade note

refs #16861

Arvados-DCO-1.1-Signed-off-by: Peter Amstutz <>

Revision 4053029e (diff)
Added by Ward Vandewege about 1 year ago

Update our docs to state a minimum requirement of Ruby 2.5, since we
don't test on 2.3 anymore.

closes #16868
refs #16861

Arvados-DCO-1.1-Signed-off-by: Ward Vandewege <>

Revision 2b5431b4 (diff)
Added by Peter Amstutz about 1 year ago

Tweak text saying which version of Ruby to install & add upgrade note

refs #16861

Arvados-DCO-1.1-Signed-off-by: Peter Amstutz <>

History

#1 Updated by Peter Amstutz about 1 year ago

  • Target version changed from 2020-10-07 Sprint to 2020-09-23 Sprint

#2 Updated by Peter Amstutz about 1 year ago

  • Description updated (diff)

#3 Updated by Peter Amstutz about 1 year ago

  • Assigned To set to Peter Amstutz

#4 Updated by Peter Amstutz about 1 year ago

  • Status changed from New to Rejected
  • Description updated (diff)
  • Subject changed from Update install docs now that minimum supported ruby version is 2.5 to Determine minimum version of Ruby we support

#5 Updated by Peter Amstutz about 1 year ago

  • Status changed from Rejected to Feedback

#6 Updated by Ward Vandewege about 1 year ago

Our documentation (https://doc.arvados.org/v2.0/install/ruby.html) states

Minimum of Ruby 2.3 is required. Ruby 2.5 is recommended.

As far as I know that is still correct.

We will be supporting Ubuntu 16.04 until at least April 2021. We will likely stop supporting Debian 9 soon.

#7 Updated by Peter Amstutz about 1 year ago

Ward Vandewege wrote:

Our documentation (https://doc.arvados.org/v2.0/install/ruby.html) states

[...]

As far as I know that is still correct.

We will be supporting Ubuntu 16.04 until at least April 2021. We will likely stop supporting Debian 9 soon.

So my point above holds, if we continue to support Ruby 2.3, it needs to be used somewhere in the test pipeline.

Right now the Debian 9 and Ubuntu 16.04 package build-and-test Dockerfiles install Ruby 2.5 from RVM. These could be changed to use the system Ruby 2.3 instead. Or we could do something else.

#8 Updated by Ward Vandewege about 1 year ago

As discussed during standup: Ruby 2.3 most likely still works, but we don't use it anymore in our tests and upstream support ended ~18 months ago (https://www.ruby-lang.org/en/news/2019/03/31/support-of-ruby-2-3-has-ended/). Update docs to state a minimum of Ruby 2.5. Users on Debian 9 and Ubuntu 16.04 will need to use RVM going forward.

#9 Updated by Peter Amstutz about 1 year ago

  • Status changed from Feedback to Resolved

#10 Updated by Peter Amstutz about 1 year ago

  • Release set to 25

Also available in: Atom PDF