Bug #16947

401 errors with search sessions when login still succeeds

Added by Peter Amstutz about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Workbench2
Target version:
Start date:
10/02/2020
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release relationship:
Auto

Description

[peer federation] [WB2]

WB2 v2.1.0.dev20201001205235, which includes the fix from #16927

When loading wb2, this error appears in red at the bottom, briefly:

Getting current user for ce8i5.arvadosapi.com: Request failed with status code 401
It re-appears on shift-reload.


Subtasks

Task #16948: Review 16947-session-validateResolvedPeter Amstutz


Related issues

Related to Arvados - Bug #16927: [Workbench2] [login federation] snackbar error on page load: Getting current user for ce8i5.arvadosapi.com: Network ErrorResolved10/01/2020

Associated revisions

Revision f56ac713
Added by Peter Amstutz about 1 year ago

Merge branch '16947-session-validate' refs #16947

Arvados-DCO-1.1-Signed-off-by: Peter Amstutz <>

Revision 17477654
Added by Peter Amstutz about 1 year ago

Merge branch '16947-session-validate' refs #16947

Arvados-DCO-1.1-Signed-off-by: Peter Amstutz <>

History

#1 Updated by Peter Amstutz about 1 year ago

  • Status changed from New to In Progress

#2 Updated by Peter Amstutz about 1 year ago

  • Description updated (diff)

#3 Updated by Peter Amstutz about 1 year ago

  • Assigned To set to Peter Amstutz

#5 Updated by Lucas Di Pentima about 1 year ago

The changes look good and make sense, but I couldn't reproduce the problem, so not sure if the reported issue is solved.

#6 Updated by Ward Vandewege about 1 year ago

  • Related to Bug #16927: [Workbench2] [login federation] snackbar error on page load: Getting current user for ce8i5.arvadosapi.com: Network Error added

#7 Updated by Peter Amstutz about 1 year ago

16947-session-validate @ arvados-workbench2|2c7ded941806dfa7da0d4e2255257a5e022efe8f

Don't report snackbar errors from validateSessions().

#8 Updated by Peter Amstutz about 1 year ago

  • Status changed from In Progress to Resolved

#9 Updated by Peter Amstutz about 1 year ago

  • Release set to 25

Also available in: Atom PDF