Bug #16971

Issues with Project and Collection name/description not being saved/shown in the edit menu.

Added by Peter Amstutz about 1 year ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Start date:
06/24/2021
Due date:
% Done:

0%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release relationship:
Auto

Description

[login federation] [experiment run from satellite cluster] [WB2]

Issues with Project and Collection name/description not being saved/shown in the edit menu.

Steps to reproduce:

Bug 1

  • go to 'Projects'
  • create new project, populate Project Name and Description fields
  • favorite it
  • go to 'my favorites'
  • right click the project, edit it
  • BUG: the Project Name and Description fields are empty

The exact same bug exists for collections.

Bug 2

  • go to 'Projects'
  • create new project, populate Project Name and Description field
  • go to 'Projects'
  • right click on the new project, edit it
  • BUG: the Description field is empty

The exact same bug exists for collections.

Bug 3

  • go to 'Projects'
  • create new project, populate Project Name and Description field
  • share the project with another user
  • log in as the other user
  • go to 'Shared with me'
  • right click on the project, click 'edit'
  • BUG: the Project Name and Description fields are empty

The exact same bug exists for collections.


Subtasks

Arvados - Task #17555: Review 16971-Issues-with-Project-and-Collection-name-description-not-being-saved-shownIn ProgressDaniel Kutyła

Associated revisions

Revision 56b5ab0d
Added by Daniel Kutyła 4 months ago

Merge branch '16971-Issues-with-Project-and-Collection-name-description-not-being-saved-shown'
closes #16971

Arvados-DCO-1.1-Signed-off-by: Daniel Kutyła <>

Revision 7edd5a7c
Added by Daniel Kutyła 4 months ago

Merge branch '16971-Issues-with-Project-and-Collection-name-description-not-being-saved-shown' into main
closes #16971

Arvados-DCO-1.1-Signed-off-by: Daniel Kutyła <>

History

#1 Updated by Peter Amstutz about 1 year ago

  • Category deleted (Workbench2)
  • Description updated (diff)

#2 Updated by Peter Amstutz 6 months ago

  • Target version set to 2021-04-28 bughunt sprint

#3 Updated by Peter Amstutz 6 months ago

  • Assigned To set to Daniel Kutyła

#4 Updated by Peter Amstutz 6 months ago

  • Target version changed from 2021-04-28 bughunt sprint to 2021-05-12 sprint

#5 Updated by Peter Amstutz 5 months ago

  • Target version changed from 2021-05-12 sprint to 2021-05-26 sprint

#6 Updated by Peter Amstutz 5 months ago

  • Related to Bug #16241: Object's description display & editing is inconsistent & lacks textile support added

#7 Updated by Peter Amstutz 5 months ago

  • Related to deleted (Bug #16241: Object's description display & editing is inconsistent & lacks textile support)

#8 Updated by Peter Amstutz 5 months ago

  • Target version changed from 2021-05-26 sprint to 2021-06-09 sprint

#9 Updated by Daniel Kutyła 5 months ago

  • Status changed from New to In Progress

#10 Updated by Peter Amstutz 5 months ago

  • Target version changed from 2021-06-09 sprint to 2021-06-23 sprint

#11 Updated by Peter Amstutz 4 months ago

  • Target version changed from 2021-06-23 sprint to 2021-07-07 sprint

#12 Updated by Daniel Kutyła 4 months ago

New version: https://dev.arvados.org/projects/arvados/repository/arvados-workbench2/revisions/836dde381f828481fd0dc20ab1356bd4c877a236
Test run: https://ci.arvados.org/job/developer-tests-workbench2/433/
Branch: 16971-Issues-with-Project-and-Collection-name-description-not-being-saved-shown

Fixed issue, added tests

#13 Updated by Lucas Di Pentima 4 months ago

  • File src/views/favorite-panel/favorite-panel.tsx - Lines 155-161: Commented out code
  • File src/views-components/context-menu/action-sets/project-action-set.ts - Line 76: Debugging console.log() call
  • The "Edit" Context menu doesn't work for projects on breadcrumbs and at the left-hand side tree panel.
  • The same issue happens in the "Public Favorites" section. This may be a sign of unnecessary duplicated code, please check if that could be eliminated.
  • The same issue also happens on "Shared with me" both at the left-hand side tree panel and the main panel.
  • The added test could also mention collection editing on its name
  • Also, the test is only checking for project/collection names but not descriptions.

#14 Updated by Daniel Kutyła 4 months ago

New version: https://dev.arvados.org/projects/arvados/repository/arvados-workbench2/revisions/7bbd67535b2ee9e8abd3342d5a9de5a22ef786a3
Test run: https://ci.arvados.org/job/developer-tests-workbench2/434/
Branch: 16971-Issues-with-Project-and-Collection-name-description-not-being-saved-shown

Added more extensible tests
I was unable to reproduce the issue with context menu any special steps required?

#15 Updated by Lucas Di Pentima 4 months ago

  • The 'can edit project in favorites' test...
    • ...is being called with it.only() (missed this at the previous review)
    • ...is also testing collection editing, so it should reflect that on its name.
  • Regarding the problems mentioned in the previous review, let me explain them better:
    • Breadcrumbs: While being inside a project, you can right-click on the project name on the "Projects > ProjName" breadcrumbs at the top of the project's panel. The "Edit Project" option has the same issue reported on this ticket.
    • Public Favorites: When you click on the "Public Favorites" section at the left-hand side tree and then right-click on a project or collection inside the public favorites listing, you have the same issue.
    • Shared with me: The same as the previous bullet point, but for the "Shared with me" section on the left-hand side tree.
  • The "Public Favorites" and "Shared with me" issues seem to make visible a code duplication issue that would be really good to eliminate instead of just duplicate the fix on them (if possible).

#16 Updated by Lucas Di Pentima 4 months ago

Also forgot to mention that if you right-click on a project at the left-hand side tree, and click on "Edit Project", it also has issues.

#17 Updated by Daniel Kutyła 4 months ago

New version: https://dev.arvados.org/projects/arvados/repository/arvados-workbench2/revisions/78e3c7b8d6a4fe84989182745267d1af468dfa7f
Test run: https://ci.arvados.org/job/developer-tests-workbench2/439/
Branch: 16971-Issues-with-Project-and-Collection-name-description-not-being-saved-shown

Fixed issues in other places

#18 Updated by Lucas Di Pentima 4 months ago

Reviewing arvados-workbench2|78e3c7b

  • The "Shared with me" case still is pending fixing.
  • Please write tests for all the failure cases.
  • In collection.spec.js there's a test called with it.only() (coming from a previous branch), please fix that too.

#19 Updated by Daniel Kutyła 4 months ago

New version: https://dev.arvados.org/projects/arvados/repository/arvados-workbench2/revisions/40ad26356794ff381c4cecb35141417dad0807ea
Test run: https://ci.arvados.org/job/developer-tests-workbench2/440/
Branch: 16971-Issues-with-Project-and-Collection-name-description-not-being-saved-shown

More tests added

#20 Updated by Lucas Di Pentima 4 months ago

A couple of small comments:

  • I think it would be nice to rename the editProjectOrCollection command to something more explicit like testEditProjectOrCollection as the command does a double-check to ensure the changes were applied, what do you think?
  • Some tests failed because of the lack of "guards" on the tests when removing objects of the UI. For example, on favorites.spec.js you do a couple of "Remove from favorites" actions, I think you need to wait for those favorites to disappear before doing anything else because if you immediately right-click on another object, the DOM can change from the previous action in between and make your test fail.

#21 Updated by Daniel Kutyła 4 months ago

New version: https://dev.arvados.org/projects/arvados/repository/arvados-workbench2/revisions/49708fe59337193ec9d00034ccd765a90536f69e
Test run: https://ci.arvados.org/job/developer-tests-workbench2/441/
Branch: 16971-Issues-with-Project-and-Collection-name-description-not-being-saved-shown

Test fixes (it was not the lack of guards but permissions)

#22 Updated by Lucas Di Pentima 4 months ago

This LGTM, thanks!

#23 Updated by Peter Amstutz 4 months ago

  • Status changed from In Progress to Resolved

#24 Updated by Peter Amstutz 4 months ago

  • Release changed from 31 to 39

Also available in: Atom PDF