Bug #16992

[arvados-api-server] automated installs gets stuck when creating the database

Added by Javier Bértoli 13 days ago. Updated 8 days ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Story points:
-

Description

Working on #16471 and testing the salt install scripts in a freshly created AWS vm (Debian buster), the installation gets stuck on the database creation. A ps awxu shows:

root     32457  1.5  1.0 181216 84500 pts/3    Sl+  12:21   0:02 ruby2.5 /var/www/arvados-api/shared/vendor_bundle/ruby/2.5.0/bin/rake db:structure:load db:seed
root     32478  0.0  0.1  21688  9260 pts/3    S+   12:21   0:00 /usr/lib/postgresql/11/bin/psql -q -f /var/www/arvados-api/current/db/structure.sql arvados

and a ps auwxf:

       |   \_ /usr/bin/apt-get -y -o DPkg::Options::=--force-confold -o DPkg::Options::=--force-confdef install arvados-api-server
       |       \_ /usr/bin/dpkg --force-confold --force-confdef --status-fd 26 --configure --pending
       |           \_ /bin/sh /var/lib/dpkg/info/arvados-api-server.postinst configure
       |               \_ ruby2.5 /var/www/arvados-api/shared/vendor_bundle/ruby/2.5.0/bin/rake db:structure:load db:seed
       |                   \_ /usr/lib/postgresql/11/bin/psql -q -f /var/www/arvados-api/current/db/structure.sql arvados
       |                       \_ sh -c pager
       |                           \_ pager

When checking postgres, nothing is being created.

Running the apt-get install arvados-api-server command manually, passes OK.

Also, disabling the psql pager with psql --pset=pager=off fixes the issue.

Associated revisions

Revision cf48ae2f
Added by Ward Vandewege 9 days ago

Merge branch '16992-disable-pg-pager' into master

closes #16992

Arvados-DCO-1.1-Signed-off-by: Ward Vandewege <>

History

#1 Updated by Peter Amstutz 13 days ago

  • Target version set to 2020-10-21 Sprint

#2 Updated by Ward Vandewege 13 days ago

  • Assigned To set to Ward Vandewege
  • Status changed from New to In Progress

#3 Updated by Ward Vandewege 13 days ago

I've disabled the pager in c20d55097c736db8881db8702ed89501020c2b5a on branch 16992-disable-pg-pager.

I've built an experimental package and attached it to this ticket as `arvados-api-server_2.1.0.dev20201010001253-1_amd64.deb`. Javier can you test it, since you have the only environment where we can reproduce this?

#4 Updated by Ward Vandewege 9 days ago

Here's a package with this patch on top of 2.1.0~rc5.

#5 Updated by Javier Bértoli 9 days ago

Ward, I can confirm it worked in my testing environment.

The test was not 100% similar to a regular install, because I had to use salt's dpkg instead of apt package installer but, given that the reported issue happens in the postinst phase, I think both methods set the salt env similarly for it.

#6 Updated by Ward Vandewege 9 days ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Resolved

Also available in: Atom PDF