Bug #17270

Test for docker cgroups issues in crunch-run works on ubuntu 20.04

Added by Peter Amstutz 9 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

the 2 options we have here is

1) Test with a single node arvados salt install and make sure that workflows run on ubuntu 20.04
2) have a compute image baked with 20.04 in one of our current clusters


Related issues

Related to Arvados - Bug #17244: Make sure cgroupsV2 works with ArvadosNew

History

#1 Updated by Peter Amstutz 9 months ago

  • Assigned To set to Nico César
  • Subject changed from Test for docker cgroups issues in crunch-run works on ubuntu 20.04 to Test for docker cgroups issues in crunch-run works on ubuntu 20.04

#2 Updated by Peter Amstutz 9 months ago

  • Description updated (diff)

#3 Updated by Nico César 9 months ago

  • Description updated (diff)

#4 Updated by Nico César 9 months ago

  • Related to Bug #17244: Make sure cgroupsV2 works with Arvados added

#5 Updated by Javier Bértoli 9 months ago

Run the provision script on a virtual machine with ubuntu 20.04, using the ubuntu-dev repo. It passes OK because ubuntu 20.04 ships systemd v45, which still uses cgroupsv1:

$ dpkg -l |grep systemd
...
ii  systemd                              245.4-4ubuntu3.4

$ cat  /sys/fs/cgroup/cgroup.controllers
cat: /sys/fs/cgroup/cgroup.controllers: No such file or directory

and running the hasher workflow passes.

#6 Updated by Javier Bértoli 9 months ago

To verify with newer systemd, I updated ubuntu's systemd package to 247.1-4ubuntu1, rebooted the instance and I found that it's still using cgroups v1.

Searching around, it seems that, due to some regressions, Ubuntu reverts Debian's systemd changes and they will ship cgroups v1 until 21.10.

So I'd say Arvados will be OK in ubuntu 20.04.

#7 Updated by Nico César 9 months ago

  • Status changed from New to Resolved

Also available in: Atom PDF