Bug #17491

[packaging] centos7 api server package build fail on CI (nokogiri version)

Added by Ward Vandewege 7 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Story points:
-
Release relationship:
Auto

Description

The api server package test for centos7 is failing with this error:

14:50:30 Running bundle install...nokogiri-1.11.2-x86_64-linux requires ruby version >= 2.5, < 3.1.dev, which is
14:50:30 incompatible with the current version, ruby 2.3.8p459
14:50:30  failed.

See e.g. https://ci.arvados.org/job/build-packages-centos7/2501/console

Associated revisions

Revision 3b9e0f69 (diff)
Added by Ward Vandewege 7 months ago

Fix centos7 api server package test.

closes #17491

Arvados-DCO-1.1-Signed-off-by: Ward Vandewege <>

History

#1 Updated by Ward Vandewege 7 months ago

  • Description updated (diff)

#2 Updated by Ward Vandewege 7 months ago

  • % Done changed from 0 to 100
  • Status changed from New to Resolved

#3 Updated by Peter Amstutz 5 months ago

  • Release set to 38

Also available in: Atom PDF