Bug #17606

[deployment][provision] extra dirs and files are poorly managed

Added by Javier Bértoli 9 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Deployment
Target version:
Start date:
05/18/2021
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release relationship:
Auto

Description

When the script finds no extra dir/files, a wildcard file is created (extras/\*) as a result.

This makes salt fail.

The loops replacing variables seem to be responsible for this.


Subtasks

Task #17641: Review #17606 provision script file-globbing-issuesResolvedLucas Di Pentima


Related issues

Blocks Arvados - Story #17512: Release Arvados 2.2Resolved05/03/2021

Associated revisions

Revision 941b5806 (diff)
Added by Javier Bértoli 8 months ago

fix(provision): prevent bash globbing issues with empty dirs

refs #17606
Arvados-DCO-1.1-Signed-off-by: Javier Bértoli <>

Revision 4b281cbb
Added by Javier Bértoli 8 months ago

Merge branch '17606-file-globbing-issues'

closes #17606
Arvados-DCO-1.1-Signed-off-by: Javier Bértoli <>

History

#1 Updated by Peter Amstutz 9 months ago

#2 Updated by Peter Amstutz 9 months ago

  • Target version changed from 2021-05-12 sprint to 2021-05-26 sprint

#3 Updated by Peter Amstutz 9 months ago

  • Assigned To changed from Javier Bértoli to Nico César

#4 Updated by Peter Amstutz 9 months ago

  • Release set to 38

#5 Updated by Javier Bértoli 8 months ago

  • Assigned To changed from Nico César to Javier Bértoli
  • Status changed from New to In Progress

#6 Updated by Javier Bértoli 8 months ago

  • Status changed from In Progress to Feedback

The issue is a bash globbing issue, so instead of using nullglob, I used a subshell to list files where required.

Tested: removed the files from config_examples/single_host/multiple_hostnames/states/, run it before and after the change and works as expected.

Fixed commit 941b5806c@arvados, branch 17606-file-globbing-issues

#7 Updated by Lucas Di Pentima 8 months ago

This LGTM, thanks!

#8 Updated by Javier Bértoli 8 months ago

  • Status changed from Feedback to Resolved

Merged

Also available in: Atom PDF