Project

General

Profile

Actions

Bug #17828

closed

bootsnap load error in arvbox

Added by Peter Amstutz over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
06/23/2021
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release relationship:
Auto

Description

Arvbox gets stuck an a loop. Usually it loads eventually but it takes many tries.

2021-06-21_20:52:50.22989 + flock /var/lib/arvados/lib/ruby/gems/2.5.0/gems.lock bundle exec rake db:migrate
2021-06-21_20:52:53.18926 rake aborted!
2021-06-21_20:52:53.18933 LoadError: cannot load such file -- omniauth-oauth2
2021-06-21_20:52:53.18942 /usr/src/arvados/services/api/lib/josh_id.rb:5:in `<main>'
2021-06-21_20:52:53.18943 /usr/src/arvados/services/api/config/environment.rb:7:in `<main>'
2021-06-21_20:52:53.18943 
2021-06-21_20:52:53.18943 Caused by:
2021-06-21_20:52:53.18944 Bootsnap::LoadPathCache::FallbackScan: 
2021-06-21_20:52:53.18944 
2021-06-21_20:52:53.18945 Tasks: TOP => db:migrate => db:load_config => environment
2021-06-21_20:52:53.18945 (See full trace by running task with --trace)

Subtasks 1 (0 open1 closed)

Task #17832: Review 17828-remove-bootsnapResolvedPeter Amstutz06/23/2021

Actions

Related issues

Related to Arvados - Story #17829: Remove josh_id / omniauth from rails APIResolvedPeter Amstutz06/23/2021

Actions
Actions #1

Updated by Peter Amstutz over 2 years ago

  • Status changed from New to In Progress
Actions #2

Updated by Peter Amstutz over 2 years ago

  • Description updated (diff)
Actions #3

Updated by Peter Amstutz over 2 years ago

  • Assigned To set to Peter Amstutz
Actions #4

Updated by Peter Amstutz over 2 years ago

  • Related to Story #17829: Remove josh_id / omniauth from rails API added
Actions #6

Updated by Peter Amstutz over 2 years ago

  • Target version changed from 2021-06-23 sprint to 2021-07-07 sprint
Actions #7

Updated by Lucas Di Pentima over 2 years ago

This LGTM, thanks!

Actions #8

Updated by Peter Amstutz over 2 years ago

  • Status changed from In Progress to Resolved
Actions #9

Updated by Peter Amstutz over 2 years ago

  • Release set to 41
Actions

Also available in: Atom PDF